summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/curl/curl_7.24.0.bb
diff options
context:
space:
mode:
authorAlexandru DAMIAN <alexandru.damian@intel.com>2012-07-04 10:31:18 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-09 16:58:56 +0100
commit460119a5b9f03db5b5f3a4668318fc3594ddf36b (patch)
tree1390b139614df0f41c36647c80385318c2e9882d /meta/recipes-support/curl/curl_7.24.0.bb
parentd0900924a6a2e08a200eecab1583a09bb2bd64f0 (diff)
downloadpoky-460119a5b9f03db5b5f3a4668318fc3594ddf36b.tar.gz
curl: upgrade to 7.26.0
Config system changed from 7.24.0 and the noldlibpatch is no longer needed, thus deleted. (From OE-Core rev: 0d2d59420b5924491ccd5c091c823b9c277a6721) Signed-off-by: Alexandru DAMIAN <alexandru.damian@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/curl/curl_7.24.0.bb')
-rw-r--r--meta/recipes-support/curl/curl_7.24.0.bb55
1 files changed, 0 insertions, 55 deletions
diff --git a/meta/recipes-support/curl/curl_7.24.0.bb b/meta/recipes-support/curl/curl_7.24.0.bb
deleted file mode 100644
index 832254ff65..0000000000
--- a/meta/recipes-support/curl/curl_7.24.0.bb
+++ /dev/null
@@ -1,55 +0,0 @@
1DESCRIPTION = "Command line tool and library for client-side URL transfers."
2HOMEPAGE = "http://curl.haxx.se/"
3BUGTRACKER = "http://curl.haxx.se/mail/list.cgi?list=curl-tracker"
4SECTION = "console/network"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://COPYING;beginline=7;md5=3a34942f4ae3fbf1a303160714e664ac"
7
8DEPENDS = "zlib gnutls"
9DEPENDS_virtclass-native = "zlib-native openssl-native"
10DEPENDS_virtclass-nativesdk = "zlib-nativesdk"
11PR = "r3"
12
13SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
14 file://noldlibpath.patch \
15 file://pkgconfig_fix.patch"
16
17SRC_URI[md5sum] = "f912221d75eb8d8fe08900eaf011b023"
18SRC_URI[sha256sum] = "ebdb111088ff8b0e05b1d1b075e9f1608285e8105cc51e21caacf33d01812c16"
19
20inherit autotools pkgconfig binconfig
21
22EXTRA_OECONF = "--with-zlib=${STAGING_LIBDIR}/../ \
23 --without-libssh2 \
24 --with-random=/dev/urandom \
25 --without-libidn \
26 --enable-crypto-auth \
27 ${CURLGNUTLS} \
28 "
29
30CURLGNUTLS = " --with-gnutls=${STAGING_LIBDIR}/../ --without-ssl"
31CURLGNUTLS_virtclass-native = "--without-gnutls --with-ssl"
32CURLGNUTLS_virtclass-nativesdk = "--without-gnutls --without-ssl"
33
34do_configure_prepend() {
35 sed -i s:OPT_GNUTLS/bin:OPT_GNUTLS:g configure.ac
36}
37
38PACKAGES =+ "${PN}-certs libcurl libcurl-dev libcurl-staticdev libcurl-doc"
39
40FILES_${PN}-certs = "${datadir}/curl/curl-*"
41PACKAGE_ARCH_${PN}-certs = "all"
42
43FILES_lib${BPN} = "${libdir}/lib*.so.*"
44RRECOMMENDS_lib${BPN} += "${PN}-certs"
45FILES_lib${BPN}-dev = "${includedir} \
46 ${libdir}/lib*.so \
47 ${libdir}/lib*.la \
48 ${libdir}/pkgconfig \
49 ${datadir}/aclocal \
50 ${bindir}/*-config"
51FILES_lib${BPN}-staticdev = "${libdir}/lib*.a"
52FILES_lib${BPN}-doc = "${mandir}/man3 \
53 ${mandir}/man1/curl-config.1"
54
55BBCLASSEXTEND = "native nativesdk"