summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/boost/boost_1.72.0.bb
diff options
context:
space:
mode:
authorViktor Rosendahl <Viktor.Rosendahl@bmw.de>2020-07-30 12:00:21 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-08-07 21:20:21 +0100
commit04d21a9ac51bc983cd89e43b4312c9f33076d239 (patch)
tree545bbb2615cad8e74c5f0d13ce91798fbba21974 /meta/recipes-support/boost/boost_1.72.0.bb
parentaba2fdcff2a6ddb4ac1872d78ea14086485923c2 (diff)
downloadpoky-04d21a9ac51bc983cd89e43b4312c9f33076d239.tar.gz
boost: backport fix to make async_pipes work with asio
async_pipe is missing the executor_type type, which is expected by asio in /usr/include/boost/asio/impl/read.hpp. Without this, it's not possible to even compile code that uses constructs such as: boost::asio::io_service foo; boost::process::async_pipe foopipe{ boost::process::async_pipe(foo) }; This is only relevant for Dunfell because master has already moved to boost-1.73.0 in which this bug has been fixed. The bug is also not present in Zeus, which uses boost-1.71.0. (From OE-Core rev: f3f6cc45b0b95cce337947df8dfaa9402251541c) Signed-off-by: Viktor Rosendahl <Viktor.Rosendahl@bmw.de> Signed-off-by: Steve Sakoman <steve@sakoman.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/boost/boost_1.72.0.bb')
-rw-r--r--meta/recipes-support/boost/boost_1.72.0.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-support/boost/boost_1.72.0.bb b/meta/recipes-support/boost/boost_1.72.0.bb
index 0b7badbc76..51c84bc935 100644
--- a/meta/recipes-support/boost/boost_1.72.0.bb
+++ b/meta/recipes-support/boost/boost_1.72.0.bb
@@ -8,4 +8,5 @@ SRC_URI += "file://arm-intrinsics.patch \
8 file://0001-Don-t-set-up-arch-instruction-set-flags-we-do-that-o.patch \ 8 file://0001-Don-t-set-up-arch-instruction-set-flags-we-do-that-o.patch \
9 file://0001-dont-setup-compiler-flags-m32-m64.patch \ 9 file://0001-dont-setup-compiler-flags-m32-m64.patch \
10 file://0001-revert-cease-dependence-on-range.patch \ 10 file://0001-revert-cease-dependence-on-range.patch \
11 file://0001-added-typedef-executor_type.patch \
11 " 12 "