summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/boost/bjam-native_1.71.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-08-26 16:26:28 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-08-28 11:31:21 +0100
commit270a33863e1e221461f85fa6f6657c462db849a1 (patch)
treeadd24a7e864f52fefb0f91aac0e56ea1dec02109 /meta/recipes-support/boost/bjam-native_1.71.0.bb
parent601c222f867bf3316ee9bdbee6f9eccb000c0042 (diff)
downloadpoky-270a33863e1e221461f85fa6f6657c462db849a1.tar.gz
boost: update to 1.71.0
Some notes: - bjam bootstrap scripts were changed, and the patch for that had to be adjusted. tools/build/src/engine/build.sh now supports an --debug option which the bjam-native recipe can use to get the debug build of b2. - a related patch was added to address a speed regression with the debug version of bjam - gcc.jam patch had to be refreshed because boost added more "cpu-flags" lines. - since 1.70.0, boost includes new cmake config files which are packaged in ${PN}-dev now so they make it into the SDK. (although 1.71.0 is needed to fix some bugs in them) (From OE-Core rev: 810aded01fc2ae2c27c2573135c20947453e50c6) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/boost/bjam-native_1.71.0.bb')
-rw-r--r--meta/recipes-support/boost/bjam-native_1.71.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-support/boost/bjam-native_1.71.0.bb b/meta/recipes-support/boost/bjam-native_1.71.0.bb
new file mode 100644
index 0000000000..d843eb038c
--- /dev/null
+++ b/meta/recipes-support/boost/bjam-native_1.71.0.bb
@@ -0,0 +1,20 @@
1require boost-${PV}.inc
2
3SUMMARY = "Portable Boost.Jam build tool for boost"
4SECTION = "devel"
5
6inherit native
7
8SRC_URI += "file://0001-Build-debug-version-of-bjam.patch \
9 file://0001-build.sh-use-DNDEBUG-also-in-debug-builds.patch \
10 "
11
12do_compile() {
13 ./bootstrap.sh --with-toolset=gcc
14}
15
16do_install() {
17 install -d ${D}${bindir}/
18 # install unstripped version for bjam
19 install -c -m 755 b2 ${D}${bindir}/bjam
20}