summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/boost/bjam-native_1.67.0.bb
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2018-04-26 23:05:32 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-04 13:28:05 +0100
commitd336110b9409d4a8c329d99e18cf23059048741c (patch)
treec64734c4d7bc9d0d67c6469fe11ef1562e579489 /meta/recipes-support/boost/bjam-native_1.67.0.bb
parentad2a0b2ef11cabdbd03c39259c69c0513a323995 (diff)
downloadpoky-d336110b9409d4a8c329d99e18cf23059048741c.tar.gz
boost: update to 1.67.0
* Remove the backported patch 0001-Fix-a-strange-assert-typo-how-was-this-released-with.patch * Remove the patch 0002-Don-t-set-up-m32-m64-we-do-that-ourselves.patch as it already rewritten gcc to use toolset.flags again as below: commit 12decb3ce680031b915f69902795eec47224fc7d Author: Steven Watanabe <steven@providere-consulting.com> Date: Mon Jan 1 12:51:43 2018 -0700 Rewrite gcc to use toolset.flags again. * Remove the hardcoded parallel build limit as the mechanism already changed as below commit: commit 316e26ca718afc65d6170029284521392524e4f8 Author: Steven Watanabe <steven@providere-consulting.com> Date: Wed Apr 26 14:22:06 2017 -0600 Remove fixed limit to -j. Fixes #189. * execunix.c: Replace select with poll. * execnt.c: Use RegisterWaitForSingleObject when the number of jobs exceeds MAXIMUM_WAIT_OBJECTS. Reference: https://github.com/boostorg/build/commit/316e26ca718afc65d6170029284521392524e4f8#diff-c88fe8afebc632d0bef2bd5985137af2 (From OE-Core rev: 358cf46ea4d01b7ad8c355fa103d4a6922cc0a88) Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/boost/bjam-native_1.67.0.bb')
-rw-r--r--meta/recipes-support/boost/bjam-native_1.67.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-support/boost/bjam-native_1.67.0.bb b/meta/recipes-support/boost/bjam-native_1.67.0.bb
new file mode 100644
index 0000000000..94f96e62d8
--- /dev/null
+++ b/meta/recipes-support/boost/bjam-native_1.67.0.bb
@@ -0,0 +1,19 @@
1require boost-${PV}.inc
2
3SUMMARY = "Portable Boost.Jam build tool for boost"
4SECTION = "devel"
5
6inherit native
7
8SRC_URI += "file://bjam-native-build-bjam.debug.patch \
9"
10
11do_compile() {
12 ./bootstrap.sh --with-toolset=gcc
13}
14
15do_install() {
16 install -d ${D}${bindir}/
17 # install unstripped version for bjam
18 install -c -m 755 bjam.debug ${D}${bindir}/bjam
19}