summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/boost/bjam-native_1.64.0.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-04-20 11:20:24 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-05-12 08:51:09 +0100
commit2b070ef738a30f23963fed4bec3470557a5dc2a3 (patch)
treeec337a9929f71b509be018b7195d4d893c5c12dc /meta/recipes-support/boost/bjam-native_1.64.0.bb
parent7ee0540f5cf55441a4af40fdbb625b6dc20fe44f (diff)
downloadpoky-2b070ef738a30f23963fed4bec3470557a5dc2a3.tar.gz
boost: Upgrade to 1.64.0
drop upstreamed patches (From OE-Core rev: 9ba71dc40dd782d192504b0827ca91f0fe180abe) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/boost/bjam-native_1.64.0.bb')
-rw-r--r--meta/recipes-support/boost/bjam-native_1.64.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-support/boost/bjam-native_1.64.0.bb b/meta/recipes-support/boost/bjam-native_1.64.0.bb
new file mode 100644
index 0000000000..46013f343b
--- /dev/null
+++ b/meta/recipes-support/boost/bjam-native_1.64.0.bb
@@ -0,0 +1,18 @@
1require boost-${PV}.inc
2
3SUMMARY = "Portable Boost.Jam build tool for boost"
4SECTION = "devel"
5
6inherit native
7
8SRC_URI += "file://bjam-native-build-bjam.debug.patch"
9
10do_compile() {
11 ./bootstrap.sh --with-toolset=gcc
12}
13
14do_install() {
15 install -d ${D}${bindir}/
16 # install unstripped version for bjam
17 install -c -m 755 bjam.debug ${D}${bindir}/bjam
18}