summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/boost/bjam-native_1.63.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2017-02-22 16:51:04 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-01 23:27:09 +0000
commit817f9b5899e386f4dd2f01d73dbda20ece7713b3 (patch)
tree47d1378c87276917f03a9277cc21229b2898754a /meta/recipes-support/boost/bjam-native_1.63.0.bb
parent76b831cc11b1eaec365f27e7f4cd37777f088b45 (diff)
downloadpoky-817f9b5899e386f4dd2f01d73dbda20ece7713b3.tar.gz
boost: update to 1.63.0
Drop backported 0002-boost-test-execution_monitor.hpp-fix-mips-soft-float.patch Rebase consider-hardfp.patch to 0001-When-using-soft-float-on-ARM-we-should-not-expect-th.patch (From OE-Core rev: ef603f41b5df4772bb598ec9d389dd5f858592af) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/boost/bjam-native_1.63.0.bb')
-rw-r--r--meta/recipes-support/boost/bjam-native_1.63.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-support/boost/bjam-native_1.63.0.bb b/meta/recipes-support/boost/bjam-native_1.63.0.bb
new file mode 100644
index 0000000000..46013f343b
--- /dev/null
+++ b/meta/recipes-support/boost/bjam-native_1.63.0.bb
@@ -0,0 +1,18 @@
1require boost-${PV}.inc
2
3SUMMARY = "Portable Boost.Jam build tool for boost"
4SECTION = "devel"
5
6inherit native
7
8SRC_URI += "file://bjam-native-build-bjam.debug.patch"
9
10do_compile() {
11 ./bootstrap.sh --with-toolset=gcc
12}
13
14do_install() {
15 install -d ${D}${bindir}/
16 # install unstripped version for bjam
17 install -c -m 755 bjam.debug ${D}${bindir}/bjam
18}