summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/argp-standalone/argp-standalone_1.3.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-12-17 08:51:39 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-24 09:40:26 +0000
commit1a6fe71e7ec2a65fe62332fa899363cf71ecc5f5 (patch)
tree040aeae2b53cdfee5db27054c7482ceff0121681 /meta/recipes-support/argp-standalone/argp-standalone_1.3.bb
parenta7d780c1bc3383514d0a2c04661203eede59b82d (diff)
downloadpoky-1a6fe71e7ec2a65fe62332fa899363cf71ecc5f5.tar.gz
argp-standalone: Add recipe
This helps packages like gnutls to compile with musl any package that needs glibc's implementation of argp can link to this library (From OE-Core rev: d2bb8bb1406ef1ca53539912a463bd518211110a) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/argp-standalone/argp-standalone_1.3.bb')
-rw-r--r--meta/recipes-support/argp-standalone/argp-standalone_1.3.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-support/argp-standalone/argp-standalone_1.3.bb b/meta/recipes-support/argp-standalone/argp-standalone_1.3.bb
new file mode 100644
index 0000000000..a5d20d30a4
--- /dev/null
+++ b/meta/recipes-support/argp-standalone/argp-standalone_1.3.bb
@@ -0,0 +1,28 @@
1# Copyright (C) 2015 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "Glibc hierarchical argument parsing standalone library"
5HOMEPAGE = "http://www.lysator.liu.se/~nisse/misc/"
6LICENSE = "LGPL-2.1"
7LIC_FILES_CHKSUM = "file://argp.h;beginline=1;endline=20;md5=008b7e53dea6f9e1d9fdef0d9cf3184a"
8SECTION = "libs"
9
10SRC_URI = "http://www.lysator.liu.se/~nisse/misc/argp-standalone-${PV}.tar.gz \
11 file://0001-throw-in-funcdef.patch \
12 file://0002-isprint.patch \
13 "
14SRC_URI[md5sum] = "720704bac078d067111b32444e24ba69"
15SRC_URI[sha256sum] = "dec79694da1319acd2238ce95df57f3680fea2482096e483323fddf3d818d8be"
16
17inherit autotools
18
19CFLAGS += "-fPIC -U__OPTIMIZE__"
20
21do_install() {
22 install -D -m 0644 ${B}/libargp.a ${D}${libdir}/libargp.a
23 install -D -m 0644 ${S}/argp.h ${D}${includedir}/argp.h
24}
25#
26# We will skip parsing for non-musl systems
27#
28COMPATIBLE_HOST = ".*-musl.*"