summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/apr/apr_1.7.0.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-08-26 00:46:46 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-08-30 10:33:35 +0100
commitb217f50dc5bea940a3e227ece215482953fd250b (patch)
tree5b07ede8fae5a3880cd65733017d6ea4df2ee47a /meta/recipes-support/apr/apr_1.7.0.bb
parentd53699101888ace9d3b8ec6772d02d8de5aea29c (diff)
downloadpoky-b217f50dc5bea940a3e227ece215482953fd250b.tar.gz
apr: Cache configure tests which use AC_TRY_RUN
AC_TRY_RUN macro means the test needs to run to find the result and we are cross compiling so this will always get wrong results, this results in miscompiling apache2 on musl because it disables rlimit (ac_cv_struct_rlimit) wrongly. All these variables are determined with AC_TRY_RUN checks (From OE-Core rev: 504eb0ff1cae200ee85ec18ebae564cae9bf9c8c) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/apr/apr_1.7.0.bb')
-rw-r--r--meta/recipes-support/apr/apr_1.7.0.bb15
1 files changed, 13 insertions, 2 deletions
diff --git a/meta/recipes-support/apr/apr_1.7.0.bb b/meta/recipes-support/apr/apr_1.7.0.bb
index 07bf61545e..cb4bb936d7 100644
--- a/meta/recipes-support/apr/apr_1.7.0.bb
+++ b/meta/recipes-support/apr/apr_1.7.0.bb
@@ -25,6 +25,7 @@ SRC_URI = "${APACHE_MIRROR}/apr/${BPN}-${PV}.tar.bz2 \
25 file://0001-Add-option-to-disable-timed-dependant-tests.patch \ 25 file://0001-Add-option-to-disable-timed-dependant-tests.patch \
26 file://autoconf270.patch \ 26 file://autoconf270.patch \
27 file://0001-add-AC_CACHE_CHECK-for-strerror_r-return-type.patch \ 27 file://0001-add-AC_CACHE_CHECK-for-strerror_r-return-type.patch \
28 file://0001-configure-Remove-runtime-test-for-mmap-that-can-map-.patch \
28 file://CVE-2021-35940.patch \ 29 file://CVE-2021-35940.patch \
29 " 30 "
30 31
@@ -37,12 +38,22 @@ OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
37 38
38# Added to fix some issues with cmake. Refer to https://github.com/bmwcarit/meta-ros/issues/68#issuecomment-19896928 39# Added to fix some issues with cmake. Refer to https://github.com/bmwcarit/meta-ros/issues/68#issuecomment-19896928
39CACHED_CONFIGUREVARS += "apr_cv_mutex_recursive=yes" 40CACHED_CONFIGUREVARS += "apr_cv_mutex_recursive=yes"
40 41# Enable largefile
42CACHED_CONFIGUREVARS += "apr_cv_use_lfs64=yes"
43# Additional AC_TRY_RUN tests which will need to be cached for cross compile
44CACHED_CONFIGUREVARS += "apr_cv_epoll=yes epoll_create1=yes apr_cv_sock_cloexec=yes \
45 ac_cv_struct_rlimit=yes \
46 ac_cv_func_sem_open=yes \
47 apr_cv_process_shared_works=yes \
48 apr_cv_mutex_robust_shared=yes \
49 "
41# Also suppress trying to use sctp. 50# Also suppress trying to use sctp.
42# 51#
43CACHED_CONFIGUREVARS += "ac_cv_header_netinet_sctp_h=no ac_cv_header_netinet_sctp_uio_h=no" 52CACHED_CONFIGUREVARS += "ac_cv_header_netinet_sctp_h=no ac_cv_header_netinet_sctp_uio_h=no"
44 53
45CACHED_CONFIGUREVARS += "ac_cv_sizeof_struct_iovec=yes" 54# ac_cv_sizeof_struct_iovec is deduced using runtime check which will fail during cross-compile
55CACHED_CONFIGUREVARS += "${@['ac_cv_sizeof_struct_iovec=16','ac_cv_sizeof_struct_iovec=8'][d.getVar('SITEINFO_BITS') != '32']}"
56
46CACHED_CONFIGUREVARS += "ac_cv_file__dev_zero=yes" 57CACHED_CONFIGUREVARS += "ac_cv_file__dev_zero=yes"
47 58
48CACHED_CONFIGUREVARS:append:libc-musl = " ac_cv_strerror_r_rc_int=yes" 59CACHED_CONFIGUREVARS:append:libc-musl = " ac_cv_strerror_r_rc_int=yes"