summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/webkit/webkitgtk_2.10.7.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-05-11 10:35:11 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-13 13:41:29 +0100
commit268f66fe0e2eddf543fda26c50ef3123c5ef6b1a (patch)
tree791ff3196c09213f040f7112ae215b3ed7894797 /meta/recipes-sato/webkit/webkitgtk_2.10.7.bb
parentb5c1f588320e6b1f1804803de9abc0bf71976f3e (diff)
downloadpoky-268f66fe0e2eddf543fda26c50ef3123c5ef6b1a.tar.gz
webkitgtk: Upgrade to 2.12.1
Fix build with gcc-6 Do not tinker with -isystem, this causes issues where gcc does not find standard C++ headers since the default search ordered for system headers is changed and is not correct anymore. Errorr like WebCore/editing/gtk/EditorGtk.cpp:27: /mnt/oe/poky/build/tmp/sysroots/qemuarm/usr/include/c++/6.0.1/cstdlib:75:25: fatal error: stdlib.h: No such file or directory #include_next <stdlib.h> It brings a patch to fix typename mismatch for pow() see https://bugs.webkit.org/show_bug.cgi?id=153071 Drop upstreamed patches User -fPIC on aarch64 to fix relocation truncated to fit: R_AARCH64_LD64_GOTPAGE_LO15 against symbol `__stack_chk_guard@@GLIBC_2.17' defined in .data.rel.ro section (From OE-Core rev: 0a6e162c47017ecf51b466218fb549e0e199f4c4) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/webkit/webkitgtk_2.10.7.bb')
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.10.7.bb87
1 files changed, 0 insertions, 87 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.10.7.bb b/meta/recipes-sato/webkit/webkitgtk_2.10.7.bb
deleted file mode 100644
index 269ae4b5e0..0000000000
--- a/meta/recipes-sato/webkit/webkitgtk_2.10.7.bb
+++ /dev/null
@@ -1,87 +0,0 @@
1SUMMARY = "WebKit web rendering engine for the GTK+ platform"
2HOMEPAGE = "http://www.webkitgtk.org/"
3BUGTRACKER = "http://bugs.webkit.org/"
4
5LICENSE = "BSD & LGPLv2+"
6LIC_FILES_CHKSUM = "file://Source/JavaScriptCore/COPYING.LIB;md5=d0c6d6397a5d84286dda758da57bd691 \
7 file://Source/WebKit/LICENSE;md5=4646f90082c40bcf298c285f8bab0b12 \
8 file://Source/WebCore/LICENSE-APPLE;md5=4646f90082c40bcf298c285f8bab0b12 \
9 file://Source/WebCore/LICENSE-LGPL-2;md5=36357ffde2b64ae177b2494445b79d21 \
10 file://Source/WebCore/LICENSE-LGPL-2.1;md5=a778a33ef338abbaf8b8a7c36b6eec80 \
11 "
12
13SRC_URI = "\
14 http://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
15 file://clang.patch \
16 file://0001-Enable-backtrace-on-linux-when-using-glibc.patch \
17 file://0001-Fix-build-with-non-glibc-libraries-on-linux.patch \
18 file://0001-FindGObjectIntrospection.cmake-prefix-variables-obta.patch \
19 file://0001-When-building-introspection-files-add-CMAKE_C_FLAGS-.patch \
20 file://0001-OptionsGTK.cmake-drop-the-hardcoded-introspection-gt.patch \
21 "
22SRC_URI[md5sum] = "84832b9d8329413b4f1d87df5f7e8efe"
23SRC_URI[sha256sum] = "990d62c82ed6dede31a6ff0a82d847f16b812842ff3e1093d17113627652864e"
24
25inherit cmake lib_package pkgconfig perlnative pythonnative distro_features_check upstream-version-is-even gobject-introspection
26
27# depends on libxt
28REQUIRED_DISTRO_FEATURES = "x11"
29
30DEPENDS = "zlib libsoup-2.4 curl libxml2 cairo libxslt libxt libidn gnutls \
31 gtk+3 gstreamer1.0 gstreamer1.0-plugins-base flex-native gperf-native sqlite3 \
32 pango icu bison-native gawk intltool-native libwebp \
33 atk udev harfbuzz jpeg libpng pulseaudio librsvg libtheora libvorbis libxcomposite libxtst \
34 ruby-native libnotify gstreamer1.0-plugins-bad \
35 "
36
37PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', 'wayland' ,d)} \
38 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'webgl', '' ,d)} \
39 enchant \
40 gtk2 \
41 libsecret \
42 "
43
44PACKAGECONFIG[wayland] = "-DENABLE_WAYLAND_TARGET=ON,-DENABLE_WAYLAND_TARGET=OFF,wayland"
45PACKAGECONFIG[x11] = "-DENABLE_X11_TARGET=ON,-DENABLE_X11_TARGET=OFF,virtual/libx11"
46PACKAGECONFIG[geoclue] = "-DENABLE_GEOLOCATION=ON,-DENABLE_GEOLOCATION=OFF,geoclue"
47PACKAGECONFIG[enchant] = "-DENABLE_SPELLCHECK=ON,-DENABLE_SPELLCHECK=OFF,enchant"
48PACKAGECONFIG[gtk2] = "-DENABLE_PLUGIN_PROCESS_GTK2=ON,-DENABLE_PLUGIN_PROCESS_GTK2=OFF,gtk+"
49PACKAGECONFIG[gles2] = "-DENABLE_GLES2=ON,-DENABLE_GLES2=OFF,virtual/libgles2"
50PACKAGECONFIG[webgl] = "-DENABLE_WEBGL=ON,-DENABLE_WEBGL=OFF,virtual/libgl"
51PACKAGECONFIG[libsecret] = "-DENABLE_CREDENTIAL_STORAGE=ON,-DENABLE_CREDENTIAL_STORAGE=OFF,libsecret"
52PACKAGECONFIG[libhyphen] = "-DUSE_LIBHYPHEN=ON,-DUSE_LIBHYPHEN=OFF,libhyphen"
53
54EXTRA_OECMAKE = " \
55 -DPORT=GTK \
56 -DCMAKE_BUILD_TYPE=Release \
57 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_INTROSPECTION=ON', '-DENABLE_INTROSPECTION=OFF', d)} \
58 -DENABLE_GTKDOC=OFF \
59 -DENABLE_MINIBROWSER=ON \
60 "
61
62# Javascript JIT is not supported on powerpc
63EXTRA_OECMAKE_append_powerpc = " -DENABLE_JIT=OFF "
64EXTRA_OECMAKE_append_powerpc64 = " -DENABLE_JIT=OFF "
65
66# ARM JIT code does not build on ARMv5/6 anymore, apparently they test only on v7 onwards
67EXTRA_OECMAKE_append_armv5 = " -DENABLE_JIT=OFF "
68EXTRA_OECMAKE_append_armv6 = " -DENABLE_JIT=OFF "
69
70# binutils 2.25.1 has a bug on aarch64:
71# https://sourceware.org/bugzilla/show_bug.cgi?id=18430
72EXTRA_OECMAKE_append_aarch64 = " -DUSE_LD_GOLD=OFF "
73
74# JIT not supported on MIPS either
75EXTRA_OECMAKE_append_mips = " -DENABLE_JIT=OFF "
76EXTRA_OECMAKE_append_mips64 = " -DENABLE_JIT=OFF "
77
78FILES_${PN} += "${libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so"
79
80# http://errors.yoctoproject.org/Errors/Details/20370/
81ARM_INSTRUCTION_SET = "arm"
82
83# Invalid data memory access: 0x00000000
84# ...
85# qemu: uncaught target signal 11 (Segmentation fault) - core dumped
86# Segmentation fault
87EXTRA_OECMAKE_append_powerpc = " -DENABLE_INTROSPECTION=OFF "