summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/settings-daemon/settings-daemon_0.0.2.bb
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2016-02-29 13:41:37 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-15 18:05:22 +0100
commit8072c7020f61c5e1a6e28d254dd967649e5a70c4 (patch)
treed89f9c3a4475f534b25b363bcd5accb94fa12bce /meta/recipes-sato/settings-daemon/settings-daemon_0.0.2.bb
parentf1dcc26187e9cfc1103bf298208bb8af1b4e9030 (diff)
downloadpoky-8072c7020f61c5e1a6e28d254dd967649e5a70c4.tar.gz
settings-daemon: Upgrade to 0.0.2
* New versions builds with gdk-x11-3.0 and supports gconf key "matchbox_theme". * Remove patch that's already upstream. (From OE-Core rev: 26694d90e9cc3024571c756445183828e2691cd4) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/settings-daemon/settings-daemon_0.0.2.bb')
-rw-r--r--meta/recipes-sato/settings-daemon/settings-daemon_0.0.2.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-sato/settings-daemon/settings-daemon_0.0.2.bb b/meta/recipes-sato/settings-daemon/settings-daemon_0.0.2.bb
new file mode 100644
index 0000000000..56eb656ecb
--- /dev/null
+++ b/meta/recipes-sato/settings-daemon/settings-daemon_0.0.2.bb
@@ -0,0 +1,29 @@
1SUMMARY = "Provides a bridge between gconf and xsettings"
2HOMEPAGE = "http://svn.o-hand.com/view/matchbox/trunk/settings-daemon/"
3BUGTRACKER = "http://bugzilla.yoctoproject.org/"
4LICENSE = "MIT-style"
5LIC_FILES_CHKSUM = "file://xsettings-manager.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b \
6 file://xsettings-common.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b"
7DEPENDS = "gconf glib-2.0 gtk+3"
8SECTION = "x11"
9
10# SRCREV tagged 0.0.2
11SRCREV = "b2e5da502f8c5ff75e9e6da771372ef8e40fd9a2"
12SRC_URI = "git://git.yoctoproject.org/xsettings-daemon \
13 file://addsoundkeys.patch;apply=yes \
14 file://70settings-daemon.sh \
15 "
16
17S = "${WORKDIR}/git"
18
19inherit autotools pkgconfig gconf distro_features_check
20
21FILES_${PN} = "${bindir}/* ${sysconfdir}"
22
23# Requires gdk-x11-2.0 which is provided by gtk when x11 in DISTRO_FEATURES
24REQUIRED_DISTRO_FEATURES = "x11"
25
26do_install_append () {
27 install -d ${D}/${sysconfdir}/X11/Xsession.d
28 install -m 755 ${WORKDIR}/70settings-daemon.sh ${D}/${sysconfdir}/X11/Xsession.d/
29}