summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/puzzles/puzzles_r9594.bb
diff options
context:
space:
mode:
authorConstantin Musca <constantinx.musca@intel.com>2012-11-09 12:00:42 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-11-12 13:36:39 +0000
commitd69683f2303a6759ee28730027e51d0aff9430e2 (patch)
tree6e97927b458e35e87fcfcb806d754a294f286397 /meta/recipes-sato/puzzles/puzzles_r9594.bb
parent1815a99f9fa290ae7dada90534b4d5db8e80a307 (diff)
downloadpoky-d69683f2303a6759ee28730027e51d0aff9430e2.tar.gz
puzzles: upgrade to r9660
License checksum change due to diff: 4,5c4,5 < K�lker, Dariusz Olszewski, Michael Schierl, Lambros Lambrou and < Bernd Schmidt. > K�lker, Dariusz Olszewski, Michael Schierl, Lambros Lambrou, Bernd > Schmidt and Steffen Bauer. (From OE-Core rev: dbf89870ae2eade8210ef6bbc9c13be17336ea68) Signed-off-by: Constantin Musca <constantinx.musca@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/puzzles/puzzles_r9594.bb')
-rw-r--r--meta/recipes-sato/puzzles/puzzles_r9594.bb62
1 files changed, 0 insertions, 62 deletions
diff --git a/meta/recipes-sato/puzzles/puzzles_r9594.bb b/meta/recipes-sato/puzzles/puzzles_r9594.bb
deleted file mode 100644
index 310798d432..0000000000
--- a/meta/recipes-sato/puzzles/puzzles_r9594.bb
+++ /dev/null
@@ -1,62 +0,0 @@
1DESCRIPTION="Simon Tatham's Portable Puzzle Collection"
2HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/puzzles/"
3
4DEPENDS = "gtk+ libxt"
5PR = "r0"
6MOD_PV = "${@d.getVar('PV',1)[1:]}"
7
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://LICENCE;md5=453de74d749439762ef4814f7bee1fec"
10
11# Upstream updates puzzles.tar.gz for the new release, so checksums seem to be changing regularly right now
12SRC_URI = "svn://svn.tartarus.org/sgt;module=puzzles;rev=${MOD_PV};protocol=svn"
13S = "${WORKDIR}/${BPN}"
14
15#SRC_URI = "http://www.chiark.greenend.org.uk/~sgtatham/puzzles/puzzles-${PV}.tar.gz"
16#SRC_URI[md5sum] = "9d84769562007e0f99edac77a3b2d27c"
17#SRC_URI[sha256sum] = "b688b5196f8406a23741e973178bdde78e5f8af4d2a88c33ca1ae1cc1a069d15"
18#S = "${WORKDIR}/${BPN}-${PV}"
19
20do_configure () {
21 ./mkfiles.pl
22}
23
24do_compile_prepend = " \
25 export XLDFLAGS='${LDFLAGS} `${STAGING_BINDIR_NATIVE}/pkg-config gtk+-2.0 --libs`'; \
26 export XLFLAGS=-lm \
27 export CFLAGS='${CFLAGS} -I./ `${STAGING_BINDIR_NATIVE}/pkg-config gtk+-2.0 --cflags`'; "
28
29FILES_${PN} = "${prefix}/games/* ${datadir}/applications/*"
30FILES_${PN}-dbg += "${prefix}/games/.debug"
31
32do_install () {
33 rm -rf ${D}/*
34 export prefix=${D}
35 export DESTDIR=${D}
36 install -d ${D}/${prefix}/
37 install -d ${D}/${prefix}/games/
38 oe_runmake install
39
40 install -d ${D}/${datadir}/
41 install -d ${D}/${datadir}/applications/
42
43 cd ${D}/${prefix}/games
44 for prog in *; do
45 if [ -x $prog ]; then
46 # Convert prog to Title Case
47 title=$(echo $prog | sed 's/\(^\| \)./\U&/g')
48 echo "making ${D}/${datadir}/applications/$prog.desktop"
49 cat <<STOP > ${D}/${datadir}/applications/$prog.desktop
50[Desktop Entry]
51Name=$title
52Exec=${prefix}/games/$prog
53Icon=applications-games
54Terminal=false
55Type=Application
56Categories=Game;
57StartupNotify=true
58X-MB-SingleInstance=true
59STOP
60 fi
61 done
62}