summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/puzzles/puzzles_r9561.bb
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2012-06-15 15:54:49 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-18 17:27:14 +0100
commit993245d2c6ac66604cdc5f3cd8d96792e4a48db6 (patch)
treef88baecd4aae2ca63e47529b69c53dea36201590 /meta/recipes-sato/puzzles/puzzles_r9561.bb
parent85c04b7f9afd92a2b89be7ec197d7cb5e2243f69 (diff)
downloadpoky-993245d2c6ac66604cdc5f3cd8d96792e4a48db6.tar.gz
puzzles: upgrade to r9561
Minor change in LICENCE file: -This software is copyright (c) 2004-2010 Simon Tatham. +This software is copyright (c) 2004-2012 Simon Tatham. (From OE-Core rev: 2f1460b7bf96616a7d54753a9dbc63ed6d322d74) Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/puzzles/puzzles_r9561.bb')
-rw-r--r--meta/recipes-sato/puzzles/puzzles_r9561.bb62
1 files changed, 62 insertions, 0 deletions
diff --git a/meta/recipes-sato/puzzles/puzzles_r9561.bb b/meta/recipes-sato/puzzles/puzzles_r9561.bb
new file mode 100644
index 0000000000..83fabdf217
--- /dev/null
+++ b/meta/recipes-sato/puzzles/puzzles_r9561.bb
@@ -0,0 +1,62 @@
1DESCRIPTION="Simon Tatham's Portable Puzzle Collection"
2HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/puzzles/"
3
4DEPENDS = "gtk+ libxt"
5PR = "r0"
6MOD_PV = "${@d.getVar('PV',1)[1:]}"
7
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://LICENCE;md5=453de74d749439762ef4814f7bee1fec"
10
11# Upstream updates puzzles.tar.gz for the new release, so checksums seem to be changing regularly right now
12#SRC_URI = "svn://ixion.tartarus.org/main;module=puzzles;rev=${MOD_PV}"
13SRC_URI = "http://www.chiark.greenend.org.uk/~sgtatham/puzzles/puzzles-${PV}.tar.gz"
14SRC_URI[md5sum] = "c86695aebfc95efe1d6241863849101b"
15SRC_URI[sha256sum] = "2c20a45189387e3de8804a58bdb4e47ac4bb0f890001a509dfbdc015b5a84b95"
16
17
18S = "${WORKDIR}/${BPN}-${PV}"
19
20do_configure () {
21 ./mkfiles.pl
22}
23
24do_compile_prepend = " \
25 export XLDFLAGS='${LDFLAGS} `${STAGING_BINDIR_NATIVE}/pkg-config gtk+-2.0 --libs`'; \
26 export XLFLAGS=-lm \
27 export CFLAGS='${CFLAGS} -I./ `${STAGING_BINDIR_NATIVE}/pkg-config gtk+-2.0 --cflags`'; "
28
29FILES_${PN} = "${prefix}/games/* ${datadir}/applications/*"
30FILES_${PN}-dbg += "${prefix}/games/.debug"
31
32do_install () {
33 rm -rf ${D}/*
34 export prefix=${D}
35 export DESTDIR=${D}
36 install -d ${D}/${prefix}/
37 install -d ${D}/${prefix}/games/
38 oe_runmake install
39
40 install -d ${D}/${datadir}/
41 install -d ${D}/${datadir}/applications/
42
43 cd ${D}/${prefix}/games
44 for prog in *; do
45 if [ -x $prog ]; then
46 # Convert prog to Title Case
47 title=$(echo $prog | sed 's/\(^\| \)./\U&/g')
48 echo "making ${D}/${datadir}/applications/$prog.desktop"
49 cat <<STOP > ${D}/${datadir}/applications/$prog.desktop
50[Desktop Entry]
51Name=$title
52Exec=${prefix}/games/$prog
53Icon=applications-games
54Terminal=false
55Type=Application
56Categories=Game;
57StartupNotify=true
58X-MB-SingleInstance=true
59STOP
60 fi
61 done
62}