summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/puzzles/puzzles_git.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2015-07-08 17:30:52 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-16 22:40:56 +0100
commit918379aecf798c7e5319dc5daf24142c27b2db6c (patch)
tree3a6157dec836409b76fac06c8fe4dc00a3e4ddf5 /meta/recipes-sato/puzzles/puzzles_git.bb
parent6e1f77c3fe67a6a67d726eea1458be38e5dc5a2a (diff)
downloadpoky-918379aecf798c7e5319dc5daf24142c27b2db6c.tar.gz
puzzles: switch svn for git, as upstream has done the same
Also, drop puzzles_x32_abi_time.patch as it has been merged upstream (From OE-Core rev: e95e6b0bdfe1bc9b71af82e3be260300232bb77e) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/puzzles/puzzles_git.bb')
-rw-r--r--meta/recipes-sato/puzzles/puzzles_git.bb60
1 files changed, 60 insertions, 0 deletions
diff --git a/meta/recipes-sato/puzzles/puzzles_git.bb b/meta/recipes-sato/puzzles/puzzles_git.bb
new file mode 100644
index 0000000000..11e922511c
--- /dev/null
+++ b/meta/recipes-sato/puzzles/puzzles_git.bb
@@ -0,0 +1,60 @@
1SUMMARY = "Simon Tatham's Portable Puzzle Collection"
2HOMEPAGE = "http://www.chiark.greenend.org.uk/~sgtatham/puzzles/"
3
4DEPENDS = "gtk+ libxt"
5
6# The libxt requires x11 in DISTRO_FEATURES
7REQUIRED_DISTRO_FEATURES = "x11"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://LICENCE;md5=33bcd4bce8f3c197f2aefbdbd2d299bc"
11
12SRC_URI = "git://git.tartarus.org/simon/puzzles.git \
13 file://fix-compiling-failure-with-option-g-O.patch \
14"
15SRCREV = "c296301a06ce49b87c954c9d15452521dfeddf1a"
16PE = "1"
17PV = "0.0+git${SRCPV}"
18
19S = "${WORKDIR}/git"
20
21inherit autotools-brokensep distro_features_check
22
23do_configure_prepend () {
24 ./mkfiles.pl
25}
26
27FILES_${PN} = "${prefix}/bin/* ${datadir}/applications/*"
28FILES_${PN}-dbg += "${prefix}/bin/.debug"
29
30do_install () {
31 rm -rf ${D}/*
32 export prefix=${D}
33 export DESTDIR=${D}
34 install -d ${D}/${prefix}/bin/
35 oe_runmake install
36
37
38 install -d ${D}/${datadir}/applications/
39
40 # Create desktop shortcuts
41 cd ${D}/${prefix}/bin
42 for prog in *; do
43 if [ -x $prog ]; then
44 # Convert prog to Title Case
45 title=$(echo $prog | sed 's/\(^\| \)./\U&/g')
46 echo "making ${D}/${datadir}/applications/$prog.desktop"
47 cat <<STOP > ${D}/${datadir}/applications/$prog.desktop
48[Desktop Entry]
49Name=$title
50Exec=${prefix}/bin/$prog
51Icon=applications-games
52Terminal=false
53Type=Application
54Categories=Game;
55StartupNotify=true
56X-MB-SingleInstance=true
57STOP
58 fi
59 done
60}