summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/puzzles/puzzles_git.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2021-05-05 17:18:07 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-05-09 23:30:15 +0100
commit537ffe0d955dc1a5d3ec925bcfd259b23336b505 (patch)
tree5cd0059975e6ad580bccc0ef21a0674ce853910f /meta/recipes-sato/puzzles/puzzles_git.bb
parent73b4bf301e8ea1356b2bebb1470ee735c37124ea (diff)
downloadpoky-537ffe0d955dc1a5d3ec925bcfd259b23336b505.tar.gz
puzzles: update to latest revision
Convert to cmake, drop all the unneeded cruft from the recipe. License-Update: additional contributors (From OE-Core rev: adba510022781f139014d6174e46954c1f4774c0) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/puzzles/puzzles_git.bb')
-rw-r--r--meta/recipes-sato/puzzles/puzzles_git.bb38
1 files changed, 5 insertions, 33 deletions
diff --git a/meta/recipes-sato/puzzles/puzzles_git.bb b/meta/recipes-sato/puzzles/puzzles_git.bb
index 16a08585cc..f5e49a4ab2 100644
--- a/meta/recipes-sato/puzzles/puzzles_git.bb
+++ b/meta/recipes-sato/puzzles/puzzles_git.bb
@@ -2,17 +2,14 @@ SUMMARY = "Simon Tatham's Portable Puzzle Collection"
2DESCRIPTION = "Collection of small computer programs which implement one-player puzzle games." 2DESCRIPTION = "Collection of small computer programs which implement one-player puzzle games."
3HOMEPAGE = "http://www.chiark.greenend.org.uk/~sgtatham/puzzles/" 3HOMEPAGE = "http://www.chiark.greenend.org.uk/~sgtatham/puzzles/"
4LICENSE = "MIT" 4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENCE;md5=6099f4981f9461d7f411091e69a7f07a" 5LIC_FILES_CHKSUM = "file://LICENCE;md5=93c2525113e094a4a744cf14d4de07e2"
6 6
7DEPENDS = "libxt" 7# gtk support includes a bunch of x11 headers
8
9# The libxt requires x11 in DISTRO_FEATURES
10REQUIRED_DISTRO_FEATURES = "x11" 8REQUIRED_DISTRO_FEATURES = "x11"
11 9
12SRC_URI = "git://git.tartarus.org/simon/puzzles.git \ 10SRC_URI = "git://git.tartarus.org/simon/puzzles.git \
13 file://fix-compiling-failure-with-option-g-O.patch \ 11 file://fix-compiling-failure-with-option-g-O.patch \
14 file://0001-palisade-Fix-warnings-with-clang-on-arm.patch \ 12 file://0001-palisade-Fix-warnings-with-clang-on-arm.patch \
15 file://0001-Use-Wno-error-format-overflow-if-the-compiler-suppor.patch \
16 file://0001-pattern.c-Change-string-lenght-parameter-to-be-size_.patch \ 13 file://0001-pattern.c-Change-string-lenght-parameter-to-be-size_.patch \
17 file://fix-ki-uninitialized.patch \ 14 file://fix-ki-uninitialized.patch \
18 file://0001-malloc-Check-for-excessive-values-to-malloc.patch \ 15 file://0001-malloc-Check-for-excessive-values-to-malloc.patch \
@@ -20,27 +17,15 @@ SRC_URI = "git://git.tartarus.org/simon/puzzles.git \
20 " 17 "
21 18
22UPSTREAM_CHECK_COMMITS = "1" 19UPSTREAM_CHECK_COMMITS = "1"
23SRCREV = "84cb4c6701e027090ff3fd955ce08065e20121b2" 20SRCREV = "c0da615a933a6676e2c6b957368067ca1bc10abd"
24PE = "2" 21PE = "2"
25PV = "0.0+git${SRCPV}" 22PV = "0.0+git${SRCPV}"
26 23
27S = "${WORKDIR}/git" 24S = "${WORKDIR}/git"
28 25
29inherit autotools features_check pkgconfig 26inherit cmake features_check pkgconfig
30
31PACKAGECONFIG ??= "gtk3"
32PACKAGECONFIG[gtk2] = "--with-gtk=2,,gtk+,"
33PACKAGECONFIG[gtk3] = "--with-gtk=3,,gtk+3,"
34
35CFLAGS_append = " -Wno-deprecated-declarations"
36
37ASNEEDED = ""
38 27
39do_configure_prepend () { 28DEPENDS += "gtk+3"
40 cd ${S}
41 ./mkfiles.pl
42 cd ${B}
43}
44 29
45do_install_append () { 30do_install_append () {
46 # net conflicts with Samba, so rename it 31 # net conflicts with Samba, so rename it
@@ -68,16 +53,3 @@ STOP
68 done 53 done
69} 54}
70 55
71PACKAGES += "${PN}-extra"
72
73FILES_${PN} = ""
74FILES_${PN}-extra = "${prefix}/bin ${datadir}/applications"
75
76python __anonymous () {
77 var = d.expand("FILES_${PN}")
78 data = d.getVar(var, False)
79 for name in ("bridges", "fifteen", "inertia", "map", "samegame", "slant"):
80 data = data + " ${bindir}/%s" % name
81 data = data + " ${datadir}/applications/%s.desktop" % name
82 d.setVar(var, data)
83}