summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/puzzles/oh-puzzles_git.bb
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2016-04-27 00:08:55 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-12 23:47:17 +0100
commit7888c74a2198ad9bb2ed6c1e78598992abbe26ac (patch)
tree46a2e04ed205c9a28fa13c4f4eb686b9fe294e24 /meta/recipes-sato/puzzles/oh-puzzles_git.bb
parentf04d8bc7dfd76a7e9871c47a62f464dbdf812c92 (diff)
downloadpoky-7888c74a2198ad9bb2ed6c1e78598992abbe26ac.tar.gz
oh-puzzles: Remove as we're using puzzles now
(From OE-Core rev: 8f930c67bf8acc39876fe29b368e5bcc15289e2b) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/puzzles/oh-puzzles_git.bb')
-rw-r--r--meta/recipes-sato/puzzles/oh-puzzles_git.bb73
1 files changed, 0 insertions, 73 deletions
diff --git a/meta/recipes-sato/puzzles/oh-puzzles_git.bb b/meta/recipes-sato/puzzles/oh-puzzles_git.bb
deleted file mode 100644
index dfa68a659b..0000000000
--- a/meta/recipes-sato/puzzles/oh-puzzles_git.bb
+++ /dev/null
@@ -1,73 +0,0 @@
1SUMMARY = "Portable Puzzle Collection"
2HOMEPAGE = "http://o-hand.com/"
3BUGTRACKER = "http://bugzilla.yoctoproject.org/"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENCE;md5=f56ec6772dd1c7c367067bbea8ea1675 \
7 file://src/tree234.h;endline=28;md5=a188e6d250430ca094a54a82f48472a7 \
8 file://src/tree234.c;endline=28;md5=b4feb1976feebf8f1379093ed52f2945"
9
10SECTION = "x11"
11DEPENDS = "gtk+ gconf intltool-native librsvg gettext-native"
12
13# libowl requires x11 in DISTRO_FEATURES
14DEPENDS_append_poky = " ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libowl', '', d)}"
15
16# Requires gdk/gdkx.h which is provided by gtk when x11 in DISTRO_FEATURES
17REQUIRED_DISTRO_FEATURES = "x11"
18
19SRCREV = "92f1a20e4b72eed7a35b00984d9793b51dc2fb3b"
20PV = "0.2+git${SRCPV}"
21PR = "r10"
22
23SRC_URI = "git://git.yoctoproject.org/${BPN}"
24SRC_URI_append_poky = " file://oh-puzzles-owl-menu.patch;striplevel=0 "
25
26S = "${WORKDIR}/git"
27
28inherit autotools pkgconfig distro_features_check
29
30bindir = "/usr/games"
31
32EXTRA_OEMAKE += "GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1"
33
34do_install_append () {
35 install -d ${D}/${datadir}/applications/
36
37 cd ${D}/${prefix}/games
38 for prog in *; do
39 if [ -x $prog ]; then
40 # Convert prog to Title Case
41 title=$(echo $prog | sed 's/\(^\| \)./\U&/g')
42 echo "making ${D}/${datadir}/applications/$prog.desktop"
43 cat <<STOP > ${D}/${datadir}/applications/$prog.desktop
44[Desktop Entry]
45Name=$title
46Exec=${prefix}/games/$prog
47Icon=applications-games
48Terminal=false
49Type=Application
50Categories=Game;
51StartupNotify=true
52X-MB-SingleInstance=true
53Comment=Play $title.
54STOP
55 fi
56 done
57}
58
59PACKAGES += "${PN}-extra"
60RDEPENDS_${PN}-extra += "oh-puzzles"
61
62FILES_${PN} = "/usr/share/pixmaps /usr/share/oh-puzzles/"
63FILES_${PN}-extra = "/usr/games/ /usr/share/applications /etc/gconf/schemas"
64
65python __anonymous () {
66 var = bb.data.expand("FILES_${PN}", d, 1)
67 data = d.getVar(var, True)
68 for name in ("bridges", "fifteen", "inertia", "map", "samegame", "slant"):
69 data = data + " /usr/games/%s" % name
70 data = data + " /usr/share/applications/%s.desktop" % name
71 data = data + " /etc/gconf/schemas/%s.schemas" % name
72 d.setVar(var, data)
73}