summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-04-22 13:43:32 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-04-23 13:00:43 +0100
commit9d734f4b3010586ffd44b631ecb03b87b9d48a38 (patch)
treef4c619377934c4e6a5843f0e3a8cc0244f72c2db /meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb
parent361d686408b9a0b2ab2f1caf2b74adfe1ad1020c (diff)
downloadpoky-9d734f4b3010586ffd44b631ecb03b87b9d48a38.tar.gz
matchbox-session-sato: install GConf values directly instead of using schemas
Because both matchbox-session-sato and settings-daemon were attempting to install their preferred values though schemas there was a race as to which ones were used. Revert matchbox-session-sato back to writing the values directly, adding a dependency on gconf-native so that this can happen on the host. (From OE-Core rev: 90ca53cbbdb1ed30883d4aa8ce9c933ae1fad5fa) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb')
-rw-r--r--meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb21
1 files changed, 13 insertions, 8 deletions
diff --git a/meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb b/meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb
index 70cf7a90d5..2d18c66f18 100644
--- a/meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb
+++ b/meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb
@@ -6,16 +6,15 @@ LICENSE = "GPLv2.0+"
6LIC_FILES_CHKSUM = "file://session;endline=3;md5=f8a5c5b9c279e52dc094d10e11c2be63" 6LIC_FILES_CHKSUM = "file://session;endline=3;md5=f8a5c5b9c279e52dc094d10e11c2be63"
7 7
8SECTION = "x11" 8SECTION = "x11"
9RDEPENDS_${PN} = "formfactor gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2 matchbox-desktop-sato matchbox-session" 9DEPENDS = "gconf-native"
10RDEPENDS_${PN} = "formfactor gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2 matchbox-desktop-sato matchbox-session gconf"
10PR = "r30" 11PR = "r30"
11 12
12# This package is architecture specific because the session script is modified 13# This package is architecture specific because the session script is modified
13# based on the machine architecture. 14# based on the machine architecture.
14PACKAGE_ARCH = "${MACHINE_ARCH}" 15PACKAGE_ARCH = "${MACHINE_ARCH}"
15 16
16SRC_URI = "file://session \ 17SRC_URI = "file://session"
17 file://matchbox-session-sato.schemas \
18 "
19S = "${WORKDIR}" 18S = "${WORKDIR}"
20 19
21do_install() { 20do_install() {
@@ -33,9 +32,15 @@ do_install() {
33 install -d ${D}/${sysconfdir}/matchbox 32 install -d ${D}/${sysconfdir}/matchbox
34 sed -f "$SCRIPT" ${S}/session > ${D}/${sysconfdir}/matchbox/session 33 sed -f "$SCRIPT" ${S}/session > ${D}/${sysconfdir}/matchbox/session
35 chmod +x ${D}/${sysconfdir}/matchbox/session 34 chmod +x ${D}/${sysconfdir}/matchbox/session
36
37 install -d ${D}/${sysconfdir}/gconf/schemas
38 install -m 664 ${S}/matchbox-session-sato.schemas ${D}/${sysconfdir}/gconf/schemas
39} 35}
40 36
41inherit gconf 37pkg_postinst_${PN} () {
38 set_value() {
39 #type, name, value
40 gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type $1 --set /desktop/poky/interface/$2 "$3"
41 }
42 set_value string theme Sato
43 set_value string icon_theme Sato
44 set_value bool touchscreen true
45 set_value string font_name "Sans 9"
46}