summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.2.bb
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2017-07-14 15:25:23 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-07-17 14:01:39 +0100
commite94b159b2e9a564ca31f81ea11c29c01c87ba89d (patch)
tree0141081be301229ede7947f32e3a7c6c1bf6d510 /meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.2.bb
parent1884950498098dcb75030da8f172e6953efa82cf (diff)
downloadpoky-e94b159b2e9a564ca31f81ea11c29c01c87ba89d.tar.gz
matchbox-desktop: Upgrade to 2.2
Only change is dropping dependency on gnome-common (which is deprecated upstream). (From OE-Core rev: 77ac45c242e65d90cda43199a33dae85dec0cd0a) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.2.bb')
-rw-r--r--meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.2.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.2.bb b/meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.2.bb
new file mode 100644
index 0000000000..b0cdfa2ae1
--- /dev/null
+++ b/meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.2.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Matchbox Window Manager Desktop"
2HOMEPAGE = "http://matchbox-project.org/"
3BUGTRACKER = "http://bugzilla.yoctoproject.org/"
4
5LICENSE = "GPLv2+ & LGPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
7 file://src/desktop.c;endline=20;md5=36c9bf295e6007f3423095f405af5a2d \
8 file://src/main.c;endline=19;md5=2044244f97a195c25b7dc602ac7e9a00"
9
10DEPENDS = "gtk+3 startup-notification dbus"
11SECTION = "x11/wm"
12
13# SRCREV tagged 2.2
14SRCREV = "6bc67d09da4147e5552fe30011a05a2c59d2f777"
15SRC_URI = "git://git.yoctoproject.org/${BPN}-2 \
16 file://vfolders/* \
17 "
18
19EXTRA_OECONF = "--enable-startup-notification --with-dbus"
20
21S = "${WORKDIR}/git"
22
23inherit autotools pkgconfig distro_features_check
24
25# The startup-notification requires x11 in DISTRO_FEATURES
26REQUIRED_DISTRO_FEATURES = "x11"
27
28do_install_append() {
29 install -d ${D}${datadir}/matchbox/vfolders/
30 install -m 0644 ${WORKDIR}/vfolders/* ${D}${datadir}/matchbox/vfolders/
31}
32
33FILES_${PN} += "${datadir}/matchbox/vfolders/"