summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/images/core-image-sato-sdk.bb
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2022-01-31 13:54:06 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-02-01 07:31:18 +0000
commit351ee239c7c5693371b80233a318ca10e0cfeb35 (patch)
tree0684e8c3a788c4527d1a40a9ff469c7c3933c739 /meta/recipes-sato/images/core-image-sato-sdk.bb
parentab6d3f806750b75ef188cac6b26a962755e00bc5 (diff)
downloadpoky-351ee239c7c5693371b80233a318ca10e0cfeb35.tar.gz
core-image-sato-sdk: allocate more memory when in qemu
Compiling code is memory-intensive, especially kernel modules like the SystemTap probes, so give the VM 768MB of RAM. Using 1GB appears to cause PCI error, interestingly. Hopefully this solves the intermittent failures caused by OOMs during the SystemTap test. [ YOCTO #14673 ] (From OE-Core rev: 50ff1f018a670c963e1979dee76ebd696153b4c1) Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/images/core-image-sato-sdk.bb')
-rw-r--r--meta/recipes-sato/images/core-image-sato-sdk.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-sato/images/core-image-sato-sdk.bb b/meta/recipes-sato/images/core-image-sato-sdk.bb
index b52de0def0..afab473b52 100644
--- a/meta/recipes-sato/images/core-image-sato-sdk.bb
+++ b/meta/recipes-sato/images/core-image-sato-sdk.bb
@@ -10,3 +10,6 @@ IMAGE_FEATURES += "dev-pkgs tools-sdk \
10 10
11IMAGE_INSTALL += "kernel-devsrc" 11IMAGE_INSTALL += "kernel-devsrc"
12 12
13# Compiling stuff, specifically SystemTap probes, can require lots of memory
14# See https://bugzilla.yoctoproject.org/show_bug.cgi?id=14673
15QB_MEM = "-m 768"