summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/eds/eds-dbus_git.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-04-19 17:26:01 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-26 10:05:19 +0100
commit41296357a90d1f3f4e870ccfb9151d77c87d6bd6 (patch)
tree7d49264b61c7fd1ca3b738ca4ecf79e0cdc59d4f /meta/recipes-sato/eds/eds-dbus_git.bb
parentcc34134e7121e3496794ce3bc78da582602408b2 (diff)
downloadpoky-41296357a90d1f3f4e870ccfb9151d77c87d6bd6.tar.gz
evolation-data-server: Rename from eds-dbus
[YOCTO #2316] (From OE-Core rev: 6189a8a05620974c098d548c26502453f371fe26) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/eds/eds-dbus_git.bb')
-rw-r--r--meta/recipes-sato/eds/eds-dbus_git.bb111
1 files changed, 0 insertions, 111 deletions
diff --git a/meta/recipes-sato/eds/eds-dbus_git.bb b/meta/recipes-sato/eds/eds-dbus_git.bb
deleted file mode 100644
index 74da2ef0d3..0000000000
--- a/meta/recipes-sato/eds/eds-dbus_git.bb
+++ /dev/null
@@ -1,111 +0,0 @@
1DESCRIPTION = "Evolution database backend server"
2HOMEPAGE = "http://www.gnome.org/projects/evolution/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "LGPLv2 & LGPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=6a6e689d19255cf0557f3fe7d7068212 \
7 file://camel/camel.h;endline=24;md5=b02175c88f821224746b347a89731a2b \
8 file://libedataserver/e-data-server-util.h;endline=23;md5=9df8127bd8cfdc5469e938fc710d1f40 \
9 file://calendar/libecal/e-cal.h;endline=24;md5=5d496b9b6fd2a4fdbbfc31ef9455c9d0"
10
11DEPENDS = "intltool-native glib-2.0 gtk+ gconf dbus db gnome-common virtual/libiconv zlib libsoup-2.4 libglade libical gnome-keyring gperf-native"
12
13SRCREV = "7337d11aed576e7caaa12b4e881ad8d33668799f"
14PV = "2.30+git${SRCPV}"
15PR = "r6"
16
17SRC_URI = "git://git.gnome.org/evolution-data-server;protocol=git \
18 file://oh-contact.patch;striplevel=0 \
19 file://nossl.patch \
20 file://optional_imapx_provider.patch \
21 file://new-contact-fix.patch \
22 file://old-gdk-api.patch \
23 file://depbuildfix.patch \
24 file://iconv-detect.h"
25
26S = "${WORKDIR}/git"
27
28inherit autotools pkgconfig
29
30# -ldb needs this on some platforms
31LDFLAGS += "-lpthread"
32
33# Parallel make shows many issues with this source code.
34# Current problems seem to be duplicate execution of the calander/backends
35# directories by make resulting in truncated/corrupt .la files
36#PARALLEL_MAKE = ""
37
38do_configure_prepend () {
39 echo "EXTRA_DIST = " > ${S}/gtk-doc.make
40}
41
42do_configure_append () {
43 cp ${WORKDIR}/iconv-detect.h ${S}
44}
45
46EXTRA_OECONF = "--without-openldap --with-dbus --without-bug-buddy \
47 --with-soup --with-libdb=${STAGING_DIR_HOST}${prefix} \
48 --disable-smime --disable-ssl --disable-nntp --disable-gtk-doc --without-weather"
49
50PACKAGES =+ "libcamel libcamel-dev libebook libebook-dev libecal libecal-dev \
51 libedata-book libedata-book-dev libedata-cal libedata-cal-dev \
52 libedataserver libedataserver-dev \
53 libedataserverui libedataserverui-dev"
54
55FILES_${PN} =+ "${datadir}/evolution-data-server-*/ui/"
56FILES_${PN}-dev =+ "${libdir}/pkgconfig/evolution-data-server-*.pc"
57FILES_${PN}-dbg =+ "${libdir}/evolution-data-server-*/camel-providers/.debug \
58 ${libdir}/evolution-data-server*/extensions/.debug/"
59RRECOMMENDS_${PN}-dev += "libecal-dev libebook-dev"
60
61FILES_libcamel = "${libexecdir}/camel-* ${libdir}/libcamel-*.so.* \
62 ${libdir}/libcamel-provider-*.so.* \
63 ${libdir}/evolution-data-server-*/camel-providers/*.so \
64 ${libdir}/evolution-data-server-*/camel-providers/*.urls"
65FILES_libcamel-dev = "${libdir}/libcamel-*.so ${libdir}/libcamel-provider-*.so \
66 ${libdir}/pkgconfig/camel*pc \
67 ${libdir}/evolution-data-server-*/camel-providers/*.la \
68 ${includedir}/evolution-data-server*/camel"
69
70FILES_libebook = "${libdir}/libebook-*.so.*"
71FILES_libebook-dev = "${libdir}/libebook-1.2.so \
72 ${libdir}/pkgconfig/libebook-*.pc \
73 ${includedir}/evolution-data-server*/libebook/*.h"
74RRECOMMENDS_libebook = "libedata-book"
75
76FILES_libecal = "${libdir}/libecal-*.so.* \
77 ${datadir}/evolution-data-server-1.4/zoneinfo"
78FILES_libecal-dev = "${libdir}/libecal-*.so ${libdir}/pkgconfig/libecal-*.pc \
79 ${includedir}/evolution-data-server*/libecal/*.h \
80 ${includedir}/evolution-data-server*/libical/*.h"
81RRECOMMENDS_libecal = "libedata-cal tzdata"
82
83FILES_libedata-book = "${libexecdir}/e-addressbook-factory \
84 ${datadir}/dbus-1/services/*.AddressBook.service \
85 ${libdir}/libedata-book-*.so.* \
86 ${libdir}/evolution-data-server-*/extensions/libebook*.so \
87 ${datadir}/evolution-data-server-1.4/weather/Locations.xml"
88FILES_libedata-book-dev = "${libdir}/libedata-book-*.so \
89 ${libdir}/pkgconfig/libedata-book-*.pc \
90 ${libdir}/evolution-data-server-*/extensions/libebook*.la \
91 ${includedir}/evolution-data-server-*/libedata-book"
92
93FILES_libedata-cal = "${libexecdir}/e-calendar-factory \
94 ${datadir}/dbus-1/services/*.Calendar.service \
95 ${libdir}/libedata-cal-*.so.* \
96 ${libdir}/evolution-data-server-*/extensions/libecal*.so"
97FILES_libedata-cal-dev = "${libdir}/libedata-cal-*.so \
98 ${libdir}/pkgconfig/libedata-cal-*.pc \
99 ${includedir}/evolution-data-server-*/libedata-cal \
100 ${libdir}/evolution-data-server-*/extensions/libecal*.la"
101
102FILES_libedataserver = "${libdir}/libedataserver-*.so.*"
103FILES_libedataserver-dev = "${libdir}/libedataserver-*.so \
104 ${libdir}/pkgconfig/libedataserver-*.pc \
105 ${includedir}/evolution-data-server-*/libedataserver/*.h"
106
107FILES_libedataserverui = "${libdir}/libedataserverui-*.so.* ${datadir}/evolution-data-server-1.4/glade/*.glade"
108FILES_libedataserverui-dev = "${libdir}/libedataserverui-*.so \
109 ${libdir}/pkgconfig/libedataserverui-*.pc \
110 ${includedir}/evolution-data-server-*/libedataserverui/*.h"
111