summaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt/rt-tests/rt-tests_1.10.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2021-01-20 15:40:58 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-01-20 22:46:18 +0000
commitcc7fa85ad2faabbe6e9a1548b74e4247fd293352 (patch)
treebe020c46950cddd007c6d8ab9e53280fd143acb3 /meta/recipes-rt/rt-tests/rt-tests_1.10.bb
parent2c1db1849edb0ca3e51079776a71e8d49d3184b3 (diff)
downloadpoky-cc7fa85ad2faabbe6e9a1548b74e4247fd293352.tar.gz
rt-tests/hwlatdetect: upgrade 1.9 -> 1.10
(From OE-Core rev: a831789158881bade4e431d88f54e4ec926d9fbe) Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-rt/rt-tests/rt-tests_1.10.bb')
-rw-r--r--meta/recipes-rt/rt-tests/rt-tests_1.10.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-rt/rt-tests/rt-tests_1.10.bb b/meta/recipes-rt/rt-tests/rt-tests_1.10.bb
new file mode 100644
index 0000000000..2834cabcd4
--- /dev/null
+++ b/meta/recipes-rt/rt-tests/rt-tests_1.10.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Real-Time preemption testcases"
2HOMEPAGE = "https://rt.wiki.kernel.org/index.php/Cyclictest"
3SECTION = "tests"
4DEPENDS = "linux-libc-headers virtual/libc numactl"
5LICENSE = "GPLv2 & GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
7
8require rt-tests.inc
9inherit ptest
10
11SRC_URI += " \
12 file://run-ptest \
13 file://rt_bmark.py \
14 file://0001-Makefile-Allow-for-CC-and-AR-to-be-overridden.patch \
15 "
16
17# rt-tests needs PI mutex support in libc
18COMPATIBLE_HOST_libc-musl = 'null'
19
20# Do not install hwlatdetect
21EXTRA_OEMAKE += "PYLIB=''"
22
23do_install() {
24 oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} \
25 INCLUDEDIR=${includedir}
26}
27
28do_install_ptest() {
29 cp ${WORKDIR}/rt_bmark.py ${D}${PTEST_PATH}
30}
31
32RDEPENDS_${PN}-ptest += " stress-ng python3 python3-multiprocessing python3-datetime python3-misc"
33
34FILES_${PN} += "${prefix}/src/backfire"
35RDEPENDS_${PN} += "bash"