summaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt/rt-tests/rt-tests_1.10.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2021-07-03 00:19:22 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-07-05 10:59:40 +0100
commit5dc897ffa662f824d9c993d0dc37c321812e3864 (patch)
treeb3ddd35daa05f847e36fce2c27cbdf0e413d5158 /meta/recipes-rt/rt-tests/rt-tests_1.10.bb
parentb3cb0947551c3972dc5bd65284b4614038a16058 (diff)
downloadpoky-5dc897ffa662f824d9c993d0dc37c321812e3864.tar.gz
rt-tests: update 1.10 -> 2.1
(From OE-Core rev: 147cf2d17cde50500aaf74627a27b614780374c0) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-rt/rt-tests/rt-tests_1.10.bb')
-rw-r--r--meta/recipes-rt/rt-tests/rt-tests_1.10.bb36
1 files changed, 0 insertions, 36 deletions
diff --git a/meta/recipes-rt/rt-tests/rt-tests_1.10.bb b/meta/recipes-rt/rt-tests/rt-tests_1.10.bb
deleted file mode 100644
index 89e3323b69..0000000000
--- a/meta/recipes-rt/rt-tests/rt-tests_1.10.bb
+++ /dev/null
@@ -1,36 +0,0 @@
1SUMMARY = "Real-Time preemption testcases"
2HOMEPAGE = "https://wiki.linuxfoundation.org/realtime/documentation/start"
3DESCRIPTION = "The main aim of the PREEMPT_RT patch is to minimize the amount of kernel code that is non-preemptible Therefore several substitution mechanisms and new mechanisms are implemented."
4SECTION = "tests"
5DEPENDS = "linux-libc-headers virtual/libc numactl"
6LICENSE = "GPLv2 & GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
8
9require rt-tests.inc
10inherit ptest
11
12SRC_URI += " \
13 file://run-ptest \
14 file://rt_bmark.py \
15 file://0001-Makefile-Allow-for-CC-and-AR-to-be-overridden.patch \
16 "
17
18# rt-tests needs PI mutex support in libc
19COMPATIBLE_HOST_libc-musl = 'null'
20
21# Do not install hwlatdetect
22EXTRA_OEMAKE += "PYLIB=''"
23
24do_install() {
25 oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} \
26 INCLUDEDIR=${includedir}
27}
28
29do_install_ptest() {
30 cp ${WORKDIR}/rt_bmark.py ${D}${PTEST_PATH}
31}
32
33RDEPENDS_${PN}-ptest += " stress-ng python3 python3-multiprocessing python3-datetime python3-misc"
34
35FILES_${PN} += "${prefix}/src/backfire"
36RDEPENDS_${PN} += "bash"