summaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt/rt-tests/rt-tests_1.1.bb
diff options
context:
space:
mode:
authorRandy Witt <randy.e.witt@intel.com>2020-10-19 14:42:14 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-10-30 13:22:48 +0000
commitf78ab0b39f7b49bff7b6d8b46b52fdcd0daf518f (patch)
tree7e9efa8cdc05c004f9ac0ea0ea3360cb4f238796 /meta/recipes-rt/rt-tests/rt-tests_1.1.bb
parentf3763062c3882d21f834511349c270ae9522ed52 (diff)
downloadpoky-f78ab0b39f7b49bff7b6d8b46b52fdcd0daf518f.tar.gz
rt-tests: Update recipes to use 1.8
John Kacur(the maintainer of rt-tests), recommends "that they use unstable/devel/latest as the maintained stable branch". I received this information on IRC, I couldn't find it documented anywhere else. This means that both rt-tests and hwlatdetect can be updated to be 1.8, the latest release on unstable/devel/latest. 0001-gzip-with-n-for-build-reproducibilty.patch was removed because upstream now uses "gzip -n" by default. (From OE-Core rev: 92b2386f0be0eac8ca761e2008288671c6f1dbb0) Signed-off-by: Randy Witt <randy.e.witt@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-rt/rt-tests/rt-tests_1.1.bb')
-rw-r--r--meta/recipes-rt/rt-tests/rt-tests_1.1.bb36
1 files changed, 0 insertions, 36 deletions
diff --git a/meta/recipes-rt/rt-tests/rt-tests_1.1.bb b/meta/recipes-rt/rt-tests/rt-tests_1.1.bb
deleted file mode 100644
index dad252b4ed..0000000000
--- a/meta/recipes-rt/rt-tests/rt-tests_1.1.bb
+++ /dev/null
@@ -1,36 +0,0 @@
1SUMMARY = "Real-Time preemption testcases"
2HOMEPAGE = "https://rt.wiki.kernel.org/index.php/Cyclictest"
3SECTION = "tests"
4DEPENDS = "linux-libc-headers virtual/libc"
5LICENSE = "GPLv2 & GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
7 file://src/cyclictest/cyclictest.c;beginline=7;endline=9;md5=e768b8da44555fe63f65e5c497844cb5 \
8 file://src/pi_tests/pi_stress.c;beginline=6;endline=19;md5=bd426a634a43ec612e9fbf125dfcc949"
9
10require rt-tests.inc
11inherit ptest
12
13SRC_URI += " \
14 file://run-ptest \
15 file://rt_bmark.py \
16 file://0001-gzip-with-n-for-build-reproducibilty.patch \
17 "
18
19# rt-tests needs PI mutex support in libc
20COMPATIBLE_HOST_libc-musl = 'null'
21
22# Do not install hwlatdetect
23EXTRA_OEMAKE += "PYLIB=''"
24
25do_install() {
26 oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} \
27 INCLUDEDIR=${includedir}
28}
29
30do_install_ptest() {
31 cp ${WORKDIR}/rt_bmark.py ${D}${PTEST_PATH}
32}
33
34RDEPENDS_${PN}-ptest += " stress-ng python3 python3-multiprocessing python3-datetime python3-misc"
35
36FILES_${PN} += "${prefix}/src/backfire"