summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/libtiff/tiff_4.6.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2023-09-22 09:24:27 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-09-26 10:35:27 +0100
commit8c5dd21254be4775a3b4aa9e60d852e941dfa255 (patch)
tree7f1507fbc5c87a22e0842f94ae18de9f21b312bb /meta/recipes-multimedia/libtiff/tiff_4.6.0.bb
parent08471afec7523500df0837c0624e8bd7737b564d (diff)
downloadpoky-8c5dd21254be4775a3b4aa9e60d852e941dfa255.tar.gz
tiff: upgrade 4.5.1 -> 4.6.0
(From OE-Core rev: 9e80f93ada4eae638350d86b8aa514203f757d43) Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/libtiff/tiff_4.6.0.bb')
-rw-r--r--meta/recipes-multimedia/libtiff/tiff_4.6.0.bb60
1 files changed, 60 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/libtiff/tiff_4.6.0.bb b/meta/recipes-multimedia/libtiff/tiff_4.6.0.bb
new file mode 100644
index 0000000000..49984f1125
--- /dev/null
+++ b/meta/recipes-multimedia/libtiff/tiff_4.6.0.bb
@@ -0,0 +1,60 @@
1SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
2DESCRIPTION = "Library provides support for the Tag Image File Format \
3(TIFF), a widely used format for storing image data. This library \
4provide means to easily access and create TIFF image files."
5HOMEPAGE = "http://www.libtiff.org/"
6LICENSE = "BSD-2-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=a3e32d664d6db1386b4689c8121531c3"
8
9CVE_PRODUCT = "libtiff"
10
11SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \
12 "
13
14SRC_URI[sha256sum] = "88b3979e6d5c7e32b50d7ec72fb15af724f6ab2cbf7e10880c360a77e4b5d99a"
15
16# exclude betas
17UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
18
19CVE_STATUS[CVE-2015-7313] = "fixed-version: Tested with check from https://security-tracker.debian.org/tracker/CVE-2015-7313 and already 4.3.0 doesn't have the issue"
20
21inherit autotools multilib_header
22
23CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
24
25PACKAGECONFIG ?= "cxx jpeg zlib lzma \
26 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
27
28PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
29PACKAGECONFIG[jbig] = "--enable-jbig,--disable-jbig,jbig,"
30PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
31PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
32PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
33PACKAGECONFIG[webp] = "--enable-webp,--disable-webp,libwebp,"
34PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd,"
35PACKAGECONFIG[libdeflate] = "--enable-libdeflate,--disable-libdeflate,libdeflate,"
36
37# Convert single-strip uncompressed images to multiple strips of specified
38# size (default: 8192) to reduce memory usage
39PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
40
41# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
42PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
43
44# Control picking up YCbCr subsample info. Disable to support files lacking
45# the tag
46PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
47
48# Support a mechanism allowing reading large strips (usually one strip files)
49# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
50PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
51
52PACKAGES =+ "tiffxx tiff-utils"
53FILES:tiffxx = "${libdir}/libtiffxx.so.*"
54FILES:tiff-utils = "${bindir}/*"
55
56do_install:append() {
57 oe_multilib_header tiffconf.h
58}
59
60BBCLASSEXTEND = "native nativesdk"