summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/libtiff/tiff_4.0.6.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2015-12-17 16:29:29 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-28 09:25:15 +0000
commitf7a7796b3769864a52982294711948463c77442d (patch)
tree08a0dbfd112ff2050e8f93c111d6bcdc8884fff0 /meta/recipes-multimedia/libtiff/tiff_4.0.6.bb
parent24980652dec4a9095026d82b8af20888e9149ffe (diff)
downloadpoky-f7a7796b3769864a52982294711948463c77442d.tar.gz
tiff: update to 4.0.6
(From OE-Core rev: 88a2a8f2f03faa19c1400a9badf16845ba217861) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/libtiff/tiff_4.0.6.bb')
-rw-r--r--meta/recipes-multimedia/libtiff/tiff_4.0.6.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/libtiff/tiff_4.0.6.bb b/meta/recipes-multimedia/libtiff/tiff_4.0.6.bb
new file mode 100644
index 0000000000..e2e24e0fb2
--- /dev/null
+++ b/meta/recipes-multimedia/libtiff/tiff_4.0.6.bb
@@ -0,0 +1,47 @@
1SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
2LICENSE = "BSD-2-Clause"
3LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=34da3db46fab7501992f9615d7e158cf"
4HOMEPAGE = "http://www.remotesensing.org/libtiff/"
5
6SRC_URI = "ftp://ftp.remotesensing.org/pub/libtiff/tiff-${PV}.tar.gz \
7 file://libtool2.patch \
8 "
9
10SRC_URI[md5sum] = "d1d2e940dea0b5ad435f21f03d96dd72"
11SRC_URI[sha256sum] = "4d57a50907b510e3049a4bba0d7888930fdfc16ce49f1bf693e5b6247370d68c"
12
13# exclude betas
14UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
15
16inherit autotools
17
18CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
19
20PACKAGECONFIG ?= "cxx jpeg zlib lzma \
21 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
22
23PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
24PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
25PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
26PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
27
28# Convert single-strip uncompressed images to multiple strips of specified
29# size (default: 8192) to reduce memory usage
30PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
31
32# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
33PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
34
35# Control picking up YCbCr subsample info. Disable to support files lacking
36# the tag
37PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
38
39# Support a mechanism allowing reading large strips (usually one strip files)
40# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
41PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
42
43PACKAGES =+ "tiffxx tiff-utils"
44FILES_tiffxx = "${libdir}/libtiffxx.so.*"
45FILES_tiff-utils = "${bindir}/*"
46
47BBCLASSEXTEND = "native"