summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/libpng/libpng_1.6.43.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-03-13 15:08:08 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-04-16 08:07:01 +0100
commit7309a6a0eddb8cfb0d79c79e58e927ca43808eb1 (patch)
tree83fe9b27d88741f52060db0683f1cba26d2c35ff /meta/recipes-multimedia/libpng/libpng_1.6.43.bb
parentf269bb70be4a91b37e35e3057c4f104ccdbc2f63 (diff)
downloadpoky-7309a6a0eddb8cfb0d79c79e58e927ca43808eb1.tar.gz
libpng: upgrade 1.6.42 -> 1.6.43
Changelog: =========== -Fixed the row width check in png_check_IHDR(). -Added eXIf chunk support to the push-mode reader in pngpread.c. -Added contrib/pngexif for the benefit of the users who would like to inspect the content of eXIf chunks. -Added contrib/conftest/basic.dfa, a basic build-time configuration. -Fixed a preprocessor condition in pngread.c that broke build-time configurations like contrib/conftest/pngcp.dfa. -Added CMake build support for LoongArch LSX. -Fixed a CMake build error that occurred under a peculiar state of the dependency tree. This was a regression introduced in libpng-1.6.41. -Marked the installed libpng headers as system headers in CMake. -Updated the build support for RISCOS. -Updated the makefiles to allow cross-platform builds to initialize conventional make variables like AR and ARFLAGS. -Added various improvements to the CI scripts in areas like version consistency verification and text linting. Added version consistency verification to pngtest.c also. (From OE-Core rev: d36edc338fde6879390c322fb6333812a2c2ed74) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/libpng/libpng_1.6.43.bb')
-rw-r--r--meta/recipes-multimedia/libpng/libpng_1.6.43.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/libpng/libpng_1.6.43.bb b/meta/recipes-multimedia/libpng/libpng_1.6.43.bb
new file mode 100644
index 0000000000..f1febd0a02
--- /dev/null
+++ b/meta/recipes-multimedia/libpng/libpng_1.6.43.bb
@@ -0,0 +1,33 @@
1SUMMARY = "PNG image format decoding library"
2DESCRIPTION = "An open source project to develop and maintain the reference \
3library for use in applications that read, create, and manipulate PNG \
4(Portable Network Graphics) raster image files. "
5HOMEPAGE = "http://www.libpng.org/"
6SECTION = "libs"
7LICENSE = "Libpng"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=0fdbfbe10fc294a6fca24dc76134222a"
9DEPENDS = "zlib"
10
11LIBV = "16"
12
13SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}${LIBV}/${BP}.tar.xz"
14SRC_URI[sha256sum] = "6a5ca0652392a2d7c9db2ae5b40210843c0bbc081cbd410825ab00cc59f14a6c"
15
16MIRRORS += "${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}${LIBV}/ ${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}${LIBV}/older-releases/"
17
18UPSTREAM_CHECK_URI = "http://libpng.org/pub/png/libpng.html"
19
20BINCONFIG = "${bindir}/libpng-config ${bindir}/libpng16-config"
21
22inherit autotools binconfig-disabled pkgconfig
23
24# Work around missing symbols
25ARMNEON = "${@bb.utils.contains("TUNE_FEATURES", "neon", "--enable-arm-neon=on", "--enable-arm-neon=off", d)}"
26ARMNEON:aarch64 = "--enable-hardware-optimizations=on"
27EXTRA_OECONF += "${ARMNEON}"
28
29PACKAGES =+ "${PN}-tools"
30
31FILES:${PN}-tools = "${bindir}/png-fix-itxt ${bindir}/pngfix ${bindir}/pngcp"
32
33BBCLASSEXTEND = "native nativesdk"