summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.16.2.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2020-02-21 10:01:17 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-02-21 17:48:08 +0000
commit1b40d5f31844e1667511458270bcc4f470e3dc5a (patch)
tree876b1abf294b16c143309d69e43e7b48a379aa2a /meta/recipes-multimedia/gstreamer/gstreamer1.0_1.16.2.bb
parenta2a03904218767d307d9adb51dd686fc4a3bb98b (diff)
downloadpoky-1b40d5f31844e1667511458270bcc4f470e3dc5a.tar.gz
gstreamer1.0: upgrade 1.16.1 -> 1.16.2
(From OE-Core rev: 174b897425f2d65129800b7d32c41103ec3a3f26) Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0_1.16.2.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0_1.16.2.bb77
1 files changed, 77 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.16.2.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.16.2.bb
new file mode 100644
index 0000000000..50a872e292
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.16.2.bb
@@ -0,0 +1,77 @@
1SUMMARY = "GStreamer 1.0 multimedia framework"
2DESCRIPTION = "GStreamer is a multimedia framework for encoding and decoding video and sound. \
3It supports a wide range of formats including mp3, ogg, avi, mpeg and quicktime."
4HOMEPAGE = "http://gstreamer.freedesktop.org/"
5BUGTRACKER = "https://bugzilla.gnome.org/enter_bug.cgi?product=Gstreamer"
6SECTION = "multimedia"
7LICENSE = "LGPLv2+"
8
9DEPENDS = "glib-2.0 glib-2.0-native libcap libxml2 bison-native flex-native"
10
11inherit meson pkgconfig gettext upstream-version-is-even gobject-introspection gtk-doc
12
13LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d \
14 file://gst/gst.h;beginline=1;endline=21;md5=e059138481205ee2c6fc1c079c016d0d"
15
16S = "${WORKDIR}/gstreamer-${PV}"
17
18SRC_URI = " \
19 https://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.xz \
20 file://0001-gst-gstpluginloader.c-when-env-var-is-set-do-not-fal.patch \
21 file://0002-meson-build-gir-even-when-cross-compiling-if-introsp.patch \
22 file://0003-meson-Add-valgrind-feature.patch \
23 file://0004-meson-Add-option-for-installed-tests.patch \
24 file://capfix.patch \
25"
26SRC_URI[md5sum] = "0e661ed5bdf1d8996e430228d022628e"
27SRC_URI[sha256sum] = "e3f044246783fd685439647373fa13ba14f7ab0b346eadd06437092f8419e94e"
28
29PACKAGECONFIG ??= "${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)} \
30 check \
31 debug \
32 tools"
33
34PACKAGECONFIG[debug] = "-Dgst_debug=true,-Dgst_debug=false"
35PACKAGECONFIG[tracer-hooks] = "-Dtracer_hooks=true,-Dtracer_hooks=false"
36PACKAGECONFIG[check] = "-Dcheck=enabled,-Dcheck=disabled"
37PACKAGECONFIG[tests] = "-Dtests=enabled -Dinstalled-tests=true,-Dtests=disabled -Dinstalled-tests=false"
38PACKAGECONFIG[valgrind] = "-Dvalgrind=enabled,-Dvalgrind=disabled,valgrind,"
39PACKAGECONFIG[unwind] = "-Dlibunwind=enabled,-Dlibunwind=disabled,libunwind"
40PACKAGECONFIG[dw] = "-Dlibdw=enabled,-Dlibdw=disabled,elfutils"
41PACKAGECONFIG[bash-completion] = "-Dbash-completion=enabled,-Dbash-completion=disabled,bash-completion"
42PACKAGECONFIG[tools] = "-Dtools=enabled,-Dtools=disabled"
43PACKAGECONFIG[setcap] = "-Dsetcap=enabled,-Dsetcap=disabled,libcap libcap-native"
44
45# TODO: put this in a gettext.bbclass patch
46def gettext_oemeson(d):
47 if d.getVar('USE_NLS') == 'no':
48 return '-Dnls=disabled'
49 # Remove the NLS bits if USE_NLS is no or INHIBIT_DEFAULT_DEPS is set
50 if d.getVar('INHIBIT_DEFAULT_DEPS') and not oe.utils.inherits(d, 'cross-canadian'):
51 return '-Dnls=disabled'
52 return '-Dnls=enabled'
53
54EXTRA_OEMESON += " \
55 -Dexamples=disabled \
56 -Ddbghelp=disabled \
57 ${@gettext_oemeson(d)} \
58"
59
60GTKDOC_MESON_OPTION = "gtk_doc"
61GTKDOC_MESON_ENABLE_FLAG = "enabled"
62GTKDOC_MESON_DISABLE_FLAG = "disabled"
63
64GIR_MESON_ENABLE_FLAG = "enabled"
65GIR_MESON_DISABLE_FLAG = "disabled"
66
67PACKAGES += "${PN}-bash-completion"
68
69# Add the core element plugins to the main package
70FILES_${PN} += "${libdir}/gstreamer-1.0/*.so"
71FILES_${PN}-dev += "${libdir}/gstreamer-1.0/*.a ${libdir}/gstreamer-1.0/include"
72FILES_${PN}-bash-completion += "${datadir}/bash-completion/completions/ ${datadir}/bash-completion/helpers/gst*"
73FILES_${PN}-dbg += "${datadir}/gdb ${datadir}/gstreamer-1.0/gdb"
74
75CVE_PRODUCT = "gstreamer"
76
77require gstreamer1.0-ptest.inc