summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.16.1.bb
diff options
context:
space:
mode:
authorCarlos Rafael Giani <crg7475@mailbox.org>2019-10-22 16:59:22 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-11-04 13:39:05 +0000
commit0f51e9a5f5992df7c4a78f0da65d80a270f8e445 (patch)
tree23d9623f2c48cf32e547cdd6c94572db8da9fef6 /meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.16.1.bb
parent412525ba410b9d8d2934372af76d2dbdd61f75e9 (diff)
downloadpoky-0f51e9a5f5992df7c4a78f0da65d80a270f8e445.tar.gz
gstreamer1.0-vaapi: upgrade to version 1.16.1
(From OE-Core rev: acdf8fa5c818f1baa3c1ee92a2e6b0bcdd85378c) Signed-off-by: Carlos Rafael Giani <crg7475@mailbox.org> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.16.1.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.16.1.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.16.1.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.16.1.bb
new file mode 100644
index 0000000000..61cf705fd8
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.16.1.bb
@@ -0,0 +1,49 @@
1SUMMARY = "VA-API support to GStreamer"
2DESCRIPTION = "gstreamer-vaapi consists of a collection of VA-API \
3based plugins for GStreamer and helper libraries: `vaapidecode', \
4`vaapiconvert', and `vaapisink'."
5
6REALPN = "gstreamer-vaapi"
7
8LICENSE = "LGPLv2.1+"
9LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
10
11SRC_URI = "https://gstreamer.freedesktop.org/src/${REALPN}/${REALPN}-${PV}.tar.xz \
12 file://0001-gst-vaapi-Makefile.am-Add-EGL_CFLAGS-to-libgstvaapi-.patch \
13 file://0001-vaapsink-downgrade-to-marginal.patch \
14 "
15
16SRC_URI[md5sum] = "15b08f76777359d87b0b4a561db05f1f"
17SRC_URI[sha256sum] = "cb570f6f1e78cb364fbe3c4fb8751824ee9db0c942ba61b62380b9b5abb7603a"
18
19S = "${WORKDIR}/${REALPN}-${PV}"
20DEPENDS = "libva gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
21
22inherit autotools pkgconfig gtk-doc distro_features_check upstream-version-is-even
23
24REQUIRED_DISTRO_FEATURES ?= "opengl"
25
26PACKAGES =+ "${PN}-tests"
27
28# OpenGL packageconfig factored out to make it easy for distros
29# and BSP layers to pick either glx, egl, or no GL. By default,
30# try detecting X11 first, and if found (with OpenGL), use GLX,
31# otherwise try to check if EGL can be used.
32PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'glx', \
33 bb.utils.contains('DISTRO_FEATURES', 'opengl', 'egl', \
34 '', d), d)}"
35
36PACKAGECONFIG ??= "drm \
37 ${PACKAGECONFIG_GL} \
38 ${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
39
40PACKAGECONFIG[drm] = "--enable-drm,--disable-drm,udev libdrm"
41PACKAGECONFIG[egl] = "--enable-egl,--disable-egl,virtual/egl"
42PACKAGECONFIG[glx] = "--enable-glx,--disable-glx,virtual/libgl"
43PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland-native wayland wayland-protocols"
44PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxrandr libxrender"
45
46FILES_${PN} += "${libdir}/gstreamer-*/*.so"
47FILES_${PN}-dbg += "${libdir}/gstreamer-*/.debug"
48FILES_${PN}-dev += "${libdir}/gstreamer-*/*.la ${libdir}/gstreamer-*/*.a"
49FILES_${PN}-tests = "${bindir}/*"