summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2023-02-10 07:42:15 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-02-15 10:21:34 +0000
commit4e07f56dced0b06d2cb60530e3989f656eede2cd (patch)
treebca1ab707f9ea795417ffa5052e59bf0f9aaf939 /meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.0.bb
parent64e6bfbff69a847202192d739e00ab1e141665bd (diff)
downloadpoky-4e07f56dced0b06d2cb60530e3989f656eede2cd.tar.gz
gstreamer1.0: update 1.20.5 -> 1.22.0
Drop xingmux license snippet from plugins-ugly as it moved to plugins-good; the license was LGPL in any case: https://gitlab.freedesktop.org/gstreamer/gstreamer/-/blob/d132592423be64ec18a223b67810ac89f391277e/subprojects/gst-plugins-good/tests/check/elements/xingmux.c videoconvert/videoscale plgins were merged into one. (From OE-Core rev: fb2d28e0315ece6180c87c7047587673024a09f7) Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.0.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.0.bb81
1 files changed, 81 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.0.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.0.bb
new file mode 100644
index 0000000000..85f8a247b1
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.22.0.bb
@@ -0,0 +1,81 @@
1require gstreamer1.0-plugins-common.inc
2
3DESCRIPTION = "'Good' GStreamer plugins"
4HOMEPAGE = "https://gstreamer.freedesktop.org/"
5BUGTRACKER = "https://gitlab.freedesktop.org/gstreamer/gst-plugins-good/-/issues"
6
7SRC_URI = "https://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-${PV}.tar.xz \
8 file://0001-qt-include-ext-qt-gstqtgl.h-instead-of-gst-gl-gstglf.patch \
9 "
10
11SRC_URI[sha256sum] = "582e617271e7f314d1a2211e3e3856ae2e4303c8c0d6114e9c4a5ea5719294b0"
12
13S = "${WORKDIR}/gst-plugins-good-${PV}"
14
15LICENSE = "LGPL-2.1-or-later"
16LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
17 file://gst/replaygain/rganalysis.c;beginline=1;endline=23;md5=b60ebefd5b2f5a8e0cab6bfee391a5fe"
18
19DEPENDS += "gstreamer1.0-plugins-base libcap zlib"
20RPROVIDES:${PN}-pulseaudio += "${PN}-pulse"
21RPROVIDES:${PN}-soup += "${PN}-souphttpsrc"
22RDEPENDS:${PN}-soup += "${MLPREFIX}${@bb.utils.contains('PACKAGECONFIG', 'soup2', 'libsoup-2.4', 'libsoup', d)}"
23
24PACKAGECONFIG_SOUP ?= "soup3"
25
26PACKAGECONFIG ??= " \
27 ${GSTREAMER_ORC} \
28 ${PACKAGECONFIG_SOUP} \
29 ${@bb.utils.filter('DISTRO_FEATURES', 'pulseaudio x11', d)} \
30 ${@bb.utils.contains('TUNE_FEATURES', 'm64', 'asm', '', d)} \
31 bz2 cairo flac gdk-pixbuf gudev jpeg lame libpng mpg123 speex taglib v4l2 \
32"
33
34X11DEPENDS = "virtual/libx11 libsm libxrender libxfixes libxdamage"
35X11ENABLEOPTS = "-Dximagesrc=enabled -Dximagesrc-xshm=enabled -Dximagesrc-xfixes=enabled -Dximagesrc-xdamage=enabled"
36X11DISABLEOPTS = "-Dximagesrc=disabled -Dximagesrc-xshm=disabled -Dximagesrc-xfixes=disabled -Dximagesrc-xdamage=disabled"
37
38QT5WAYLANDDEPENDS = "${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
39
40PACKAGECONFIG[asm] = "-Dasm=enabled,-Dasm=disabled,nasm-native"
41PACKAGECONFIG[bz2] = "-Dbz2=enabled,-Dbz2=disabled,bzip2"
42PACKAGECONFIG[cairo] = "-Dcairo=enabled,-Dcairo=disabled,cairo"
43PACKAGECONFIG[dv1394] = "-Ddv1394=enabled,-Ddv1394=disabled,libiec61883 libavc1394 libraw1394"
44PACKAGECONFIG[flac] = "-Dflac=enabled,-Dflac=disabled,flac"
45PACKAGECONFIG[gdk-pixbuf] = "-Dgdk-pixbuf=enabled,-Dgdk-pixbuf=disabled,gdk-pixbuf"
46PACKAGECONFIG[gtk] = "-Dgtk3=enabled,-Dgtk3=disabled,gtk+3"
47PACKAGECONFIG[gudev] = "-Dv4l2-gudev=enabled,-Dv4l2-gudev=disabled,libgudev"
48PACKAGECONFIG[jack] = "-Djack=enabled,-Djack=disabled,jack"
49PACKAGECONFIG[jpeg] = "-Djpeg=enabled,-Djpeg=disabled,jpeg"
50PACKAGECONFIG[lame] = "-Dlame=enabled,-Dlame=disabled,lame"
51PACKAGECONFIG[libpng] = "-Dpng=enabled,-Dpng=disabled,libpng"
52PACKAGECONFIG[libv4l2] = "-Dv4l2-libv4l2=enabled,-Dv4l2-libv4l2=disabled,v4l-utils"
53PACKAGECONFIG[mpg123] = "-Dmpg123=enabled,-Dmpg123=disabled,mpg123"
54PACKAGECONFIG[pulseaudio] = "-Dpulse=enabled,-Dpulse=disabled,pulseaudio"
55PACKAGECONFIG[qt5] = "-Dqt5=enabled,-Dqt5=disabled,qtbase qtdeclarative qtbase-native ${QT5WAYLANDDEPENDS}"
56PACKAGECONFIG[soup2] = "-Dsoup=enabled,,libsoup-2.4,,,soup3"
57PACKAGECONFIG[soup3] = "-Dsoup=enabled,,libsoup,,,soup2"
58PACKAGECONFIG[speex] = "-Dspeex=enabled,-Dspeex=disabled,speex"
59PACKAGECONFIG[rpi] = "-Drpicamsrc=enabled,-Drpicamsrc=disabled,userland"
60PACKAGECONFIG[taglib] = "-Dtaglib=enabled,-Dtaglib=disabled,taglib"
61PACKAGECONFIG[v4l2] = "-Dv4l2=enabled -Dv4l2-probe=true,-Dv4l2=disabled -Dv4l2-probe=false"
62PACKAGECONFIG[vpx] = "-Dvpx=enabled,-Dvpx=disabled,libvpx"
63PACKAGECONFIG[wavpack] = "-Dwavpack=enabled,-Dwavpack=disabled,wavpack"
64PACKAGECONFIG[x11] = "${X11ENABLEOPTS},${X11DISABLEOPTS},${X11DEPENDS}"
65
66EXTRA_OEMESON += " \
67 -Ddoc=disabled \
68 -Daalib=disabled \
69 -Ddirectsound=disabled \
70 -Ddv=disabled \
71 -Dlibcaca=disabled \
72 -Doss=enabled \
73 -Doss4=disabled \
74 -Dosxaudio=disabled \
75 -Dosxvideo=disabled \
76 -Dshout2=disabled \
77 -Dtwolame=disabled \
78 -Dwaveform=disabled \
79"
80
81FILES:${PN}-equalizer += "${datadir}/gstreamer-1.0/presets/*.prs"