summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.22.6.bb
diff options
context:
space:
mode:
authorArchana Polampalli <archana.polampalli@windriver.com>2023-10-05 09:19:12 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-10-06 11:51:11 +0100
commitd87f113d9f924f488f15bfb59fe85e9c65333bcf (patch)
tree71d52b37261181d6b1186a21c71627fb6c9a9582 /meta/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.22.6.bb
parenta570227bb74d4abd8d1286c40c63b89e2f0a25ce (diff)
downloadpoky-d87f113d9f924f488f15bfb59fe85e9c65333bcf.tar.gz
gstreamer: upgrade 1.22.5 -> 1.22.6
This release only contains bugfixes and security fixes. Highlighted bugfixes in 1.22.6: Security fixes for the MXF demuxer and H.265 video parser Fix latency regression in H.264 hardware decoder base class androidmedia: fix HEVC codec profile registration and fix coded_data handling decodebin3: fix switching from a raw stream to an encoded stream gst-inspect: prettier and more correct signal and action signals printing rtmp2: Allow NULL flash version, omitting the field, for better RTMP server compatibility rtspsrc: better compatibility with buggy RTSP servers that don't set a clock-rate rtpjitterbuffer: fix integer overflow that led to more packets being declared lost than have been lost v4l2: fix video encoding regression on RPi and fix support for left and top padding waylandsink: Crop surfaces to their display width height cerbero: recognise Manjaro; add Rust support for MSVC ARM64; cmake detection fixes various bug fixes, build fixes, memory leak fixes, and other stability and reliability improvements https://nvd.nist.gov/vuln/detail/CVE-2023-40475 https://nvd.nist.gov/vuln/detail/CVE-2023-40476 https://gstreamer.freedesktop.org/releases/1.22/#1.22.6 (From OE-Core rev: ff2fc789e08c42903f5e528d4836dd482227291c) Signed-off-by: Archana Polampalli <archana.polampalli@windriver.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.22.6.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.22.6.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.22.6.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.22.6.bb
new file mode 100644
index 0000000000..2579aa3d66
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.22.6.bb
@@ -0,0 +1,47 @@
1SUMMARY = "OpenMAX IL plugins for GStreamer"
2DESCRIPTION = "Wraps available OpenMAX IL components and makes them available as standard GStreamer elements."
3HOMEPAGE = "http://gstreamer.freedesktop.org/"
4SECTION = "multimedia"
5
6LICENSE = "LGPL-2.1-or-later"
7LICENSE_FLAGS = "commercial"
8LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \
9 file://omx/gstomx.h;beginline=1;endline=21;md5=5c8e1fca32704488e76d2ba9ddfa935f"
10
11SRC_URI = "https://gstreamer.freedesktop.org/src/gst-omx/gst-omx-${PV}.tar.xz"
12
13SRC_URI[sha256sum] = "223833c42518ad7eb1923bb4dd3726809f59a66d6e9aaaa69cb29ad0750c8758"
14
15S = "${WORKDIR}/gst-omx-${PV}"
16
17DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad virtual/libomxil"
18
19inherit meson pkgconfig upstream-version-is-even
20
21GSTREAMER_1_0_OMX_TARGET ?= "bellagio"
22GSTREAMER_1_0_OMX_CORE_NAME ?= "${libdir}/libomxil-bellagio.so.0"
23
24EXTRA_OEMESON += "-Dtarget=${GSTREAMER_1_0_OMX_TARGET}"
25
26python __anonymous () {
27 omx_target = d.getVar("GSTREAMER_1_0_OMX_TARGET")
28 if omx_target in ['generic', 'bellagio']:
29 # Bellagio headers are incomplete (they are missing the OMX_VERSION_MAJOR,#
30 # OMX_VERSION_MINOR, OMX_VERSION_REVISION, and OMX_VERSION_STEP macros);
31 # appending a directory path to gst-omx' internal OpenMAX IL headers fixes this
32 d.appendVar("CFLAGS", " -I${S}/omx/openmax")
33 elif omx_target == "rpi":
34 # Dedicated Raspberry Pi OpenMAX IL support makes this package machine specific
35 d.setVar("PACKAGE_ARCH", d.getVar("MACHINE_ARCH"))
36}
37
38set_omx_core_name() {
39 sed -i -e "s;^core-name=.*;core-name=${GSTREAMER_1_0_OMX_CORE_NAME};" "${D}${sysconfdir}/xdg/gstomx.conf"
40}
41do_install[postfuncs] += " set_omx_core_name "
42
43FILES:${PN} += "${libdir}/gstreamer-1.0/*.so"
44FILES:${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a"
45
46VIRTUAL-RUNTIME_libomxil ?= "libomxil"
47RDEPENDS:${PN} = "${VIRTUAL-RUNTIME_libomxil}"