summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.22.4.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-06-27 15:16:59 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-06-28 07:56:33 +0100
commit9d7b581b330b68d48933afb9fdc0c6c7a450e282 (patch)
tree8afc9bb187f247abd8fc4842e20550454f5e9982 /meta/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.22.4.bb
parent31f99698b5449aba354d92e497804bfca455e6ae (diff)
downloadpoky-9d7b581b330b68d48933afb9fdc0c6c7a450e282.tar.gz
gstreamer1.0: upgrade 1.22.3 -> 1.22.4
Bugfixes: ========== - Security fixes for flacparse, dvdspu, and subparse - d3d11videosink: Fix error on pause and play - decklink: Correctly handle SDK strings on macOS and free strings after usage on Linux - filesink: Fix buffered mode writing of buffer lists and buffers with multiple memories - gldownload: handle passthrough without a critical - h265parse: Fix framerate handling regression - oggdemux: vp8 fixes - mp4mux, qtmux, qtdemux: Opus audio mapping fixes - pngdec: Fix wrong colours output from 16bit RGB images - ptp clock: Work around ptpd bug in default configuration - srtpdec: fix critical warnings on shutdown - v4l2src: fix support for bayer format - v4l2videoenc: support force-keyframe event in v4l2 encoder - vtenc: apply DTS offset to ensure DTS <= PTS - gst-python: allow more functions to be called before gst_init() - cerbero: fix vaapi variant; add qt6 build on windows; ensure errors on unguarded use of new APIs, require macOS 10.13 - packages: ship codecalpha, rtponvif, dvbsubenc, switchbin, videosignal plugins; fix pango crash on 32-bit windows - various bug fixes, memory leak fixes, and other stability and reliability improvements (From OE-Core rev: d7bf88db7f2f55540bf7891474a3a28f5681ddbb) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.22.4.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.22.4.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.22.4.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.22.4.bb
new file mode 100644
index 0000000000..fc70805daf
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.22.4.bb
@@ -0,0 +1,47 @@
1SUMMARY = "OpenMAX IL plugins for GStreamer"
2DESCRIPTION = "Wraps available OpenMAX IL components and makes them available as standard GStreamer elements."
3HOMEPAGE = "http://gstreamer.freedesktop.org/"
4SECTION = "multimedia"
5
6LICENSE = "LGPL-2.1-or-later"
7LICENSE_FLAGS = "commercial"
8LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \
9 file://omx/gstomx.h;beginline=1;endline=21;md5=5c8e1fca32704488e76d2ba9ddfa935f"
10
11SRC_URI = "https://gstreamer.freedesktop.org/src/gst-omx/gst-omx-${PV}.tar.xz"
12
13SRC_URI[sha256sum] = "5fcb872d977b035fb75a2d0ea955ba052dc3bdae282f8f60aa9d865808784211"
14
15S = "${WORKDIR}/gst-omx-${PV}"
16
17DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad virtual/libomxil"
18
19inherit meson pkgconfig upstream-version-is-even
20
21GSTREAMER_1_0_OMX_TARGET ?= "bellagio"
22GSTREAMER_1_0_OMX_CORE_NAME ?= "${libdir}/libomxil-bellagio.so.0"
23
24EXTRA_OEMESON += "-Dtarget=${GSTREAMER_1_0_OMX_TARGET}"
25
26python __anonymous () {
27 omx_target = d.getVar("GSTREAMER_1_0_OMX_TARGET")
28 if omx_target in ['generic', 'bellagio']:
29 # Bellagio headers are incomplete (they are missing the OMX_VERSION_MAJOR,#
30 # OMX_VERSION_MINOR, OMX_VERSION_REVISION, and OMX_VERSION_STEP macros);
31 # appending a directory path to gst-omx' internal OpenMAX IL headers fixes this
32 d.appendVar("CFLAGS", " -I${S}/omx/openmax")
33 elif omx_target == "rpi":
34 # Dedicated Raspberry Pi OpenMAX IL support makes this package machine specific
35 d.setVar("PACKAGE_ARCH", d.getVar("MACHINE_ARCH"))
36}
37
38set_omx_core_name() {
39 sed -i -e "s;^core-name=.*;core-name=${GSTREAMER_1_0_OMX_CORE_NAME};" "${D}${sysconfdir}/xdg/gstomx.conf"
40}
41do_install[postfuncs] += " set_omx_core_name "
42
43FILES:${PN} += "${libdir}/gstreamer-1.0/*.so"
44FILES:${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a"
45
46VIRTUAL-RUNTIME_libomxil ?= "libomxil"
47RDEPENDS:${PN} = "${VIRTUAL-RUNTIME_libomxil}"