summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.22.11.bb
diff options
context:
space:
mode:
authorRandy MacLeod <Randy.MacLeod@windriver.com>2024-03-28 12:40:52 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-03-30 22:22:19 +0000
commitb84ae2ad79e31c33c42ed36d58c47b2c1d11509b (patch)
treef28a5b503c0600977dbf759a2c7849b9ec5903dd /meta/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.22.11.bb
parent7c916d8f1bfd6b8036311d534a08b2f71464a3cd (diff)
downloadpoky-b84ae2ad79e31c33c42ed36d58c47b2c1d11509b.tar.gz
gstreamer: upgrade 1.22.10 -> 1.22.11
Changelog: https://gstreamer.freedesktop.org/releases/1.22/#1.22.11 Change the Upstream-Status URL for patch: 0002-ssaparse-enhance-SSA-text-lines-parsing.patch since the bug tracker moved but the bug is not yet resolved. "gstreamer 1.22.9 and 1.22.10 contain a regression that cause the audio output to freeze when muting. this regression has been fixed in 1.22.11" [YOCTO #15456] (From OE-Core rev: cad5d53e13093ac2fc6f5ba1d0e26fb16e3d88f7) Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.22.11.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.22.11.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.22.11.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.22.11.bb
new file mode 100644
index 0000000000..97348fb398
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.22.11.bb
@@ -0,0 +1,47 @@
1SUMMARY = "OpenMAX IL plugins for GStreamer"
2DESCRIPTION = "Wraps available OpenMAX IL components and makes them available as standard GStreamer elements."
3HOMEPAGE = "http://gstreamer.freedesktop.org/"
4SECTION = "multimedia"
5
6LICENSE = "LGPL-2.1-or-later"
7LICENSE_FLAGS = "commercial"
8LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \
9 file://omx/gstomx.h;beginline=1;endline=21;md5=5c8e1fca32704488e76d2ba9ddfa935f"
10
11SRC_URI = "https://gstreamer.freedesktop.org/src/gst-omx/gst-omx-${PV}.tar.xz"
12
13SRC_URI[sha256sum] = "18dfdf5f6b773d67e62a315c6cf6247da320b83603a5819493f53c69ed2eeef6"
14
15S = "${WORKDIR}/gst-omx-${PV}"
16
17DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad virtual/libomxil"
18
19inherit meson pkgconfig upstream-version-is-even
20
21GSTREAMER_1_0_OMX_TARGET ?= "bellagio"
22GSTREAMER_1_0_OMX_CORE_NAME ?= "${libdir}/libomxil-bellagio.so.0"
23
24EXTRA_OEMESON += "-Dtarget=${GSTREAMER_1_0_OMX_TARGET}"
25
26python __anonymous () {
27 omx_target = d.getVar("GSTREAMER_1_0_OMX_TARGET")
28 if omx_target in ['generic', 'bellagio']:
29 # Bellagio headers are incomplete (they are missing the OMX_VERSION_MAJOR,#
30 # OMX_VERSION_MINOR, OMX_VERSION_REVISION, and OMX_VERSION_STEP macros);
31 # appending a directory path to gst-omx' internal OpenMAX IL headers fixes this
32 d.appendVar("CFLAGS", " -I${S}/omx/openmax")
33 elif omx_target == "rpi":
34 # Dedicated Raspberry Pi OpenMAX IL support makes this package machine specific
35 d.setVar("PACKAGE_ARCH", d.getVar("MACHINE_ARCH"))
36}
37
38set_omx_core_name() {
39 sed -i -e "s;^core-name=.*;core-name=${GSTREAMER_1_0_OMX_CORE_NAME};" "${D}${sysconfdir}/xdg/gstomx.conf"
40}
41do_install[postfuncs] += " set_omx_core_name "
42
43FILES:${PN} += "${libdir}/gstreamer-1.0/*.so"
44FILES:${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a"
45
46VIRTUAL-RUNTIME_libomxil ?= "libomxil"
47RDEPENDS:${PN} = "${VIRTUAL-RUNTIME_libomxil}"