summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.14.4.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2018-11-27 16:55:22 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-08 20:14:43 +0000
commit499c3f1b18919c6d461d080b35592272829910ed (patch)
tree1adaf125baebf4fc879984125b7ef54fc4cee39e /meta/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.14.4.bb
parentf1273ebf042e865004c4ace7227f32af8c317eac (diff)
downloadpoky-499c3f1b18919c6d461d080b35592272829910ed.tar.gz
gstreamer1.0-omx: upgrade 1.14.3 -> 1.14.4
(From OE-Core rev: 9b613f029490a3540492393206be004b649c0806) (From OE-Core rev: 4f431f740186a2d5ab8cc0f592f6d8e908411637) Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.14.4.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.14.4.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.14.4.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.14.4.bb
new file mode 100644
index 0000000000..39ca1e3854
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.14.4.bb
@@ -0,0 +1,57 @@
1SUMMARY = "OpenMAX IL plugins for GStreamer"
2HOMEPAGE = "http://gstreamer.freedesktop.org/"
3SECTION = "multimedia"
4
5LICENSE = "LGPLv2.1"
6LICENSE_FLAGS = "commercial"
7LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \
8 file://omx/gstomx.h;beginline=1;endline=21;md5=5c8e1fca32704488e76d2ba9ddfa935f"
9
10SRC_URI = "http://gstreamer.freedesktop.org/src/gst-omx/gst-omx-${PV}.tar.xz"
11
12SRC_URI[md5sum] = "81e67ea03be607b7c548ce911598d754"
13SRC_URI[sha256sum] = "969870e75c1f75c96f8783530e2c2932fc3afbfd976eb0c466f51dae268ea3d4"
14
15S = "${WORKDIR}/gst-omx-${PV}"
16
17DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
18
19inherit autotools pkgconfig gettext gtk-doc upstream-version-is-even
20
21acpaths = "-I ${S}/common/m4 -I ${S}/m4"
22
23GSTREAMER_1_0_OMX_TARGET ?= "bellagio"
24GSTREAMER_1_0_OMX_CORE_NAME ?= "${libdir}/libomxil-bellagio.so.0"
25
26EXTRA_OECONF += "--disable-valgrind --with-omx-target=${GSTREAMER_1_0_OMX_TARGET}"
27
28python __anonymous () {
29 omx_target = d.getVar("GSTREAMER_1_0_OMX_TARGET")
30 if omx_target in ['generic', 'bellagio']:
31 # Bellagio headers are incomplete (they are missing the OMX_VERSION_MAJOR,#
32 # OMX_VERSION_MINOR, OMX_VERSION_REVISION, and OMX_VERSION_STEP macros);
33 # appending a directory path to gst-omx' internal OpenMAX IL headers fixes this
34 d.appendVar("CFLAGS", " -I${S}/omx/openmax")
35 elif omx_target == "rpi":
36 # Dedicated Raspberry Pi OpenMAX IL support makes this package machine specific
37 d.setVar("PACKAGE_ARCH", d.getVar("MACHINE_ARCH"))
38}
39
40delete_pkg_m4_file() {
41 # Delete m4 files which we provide patched versions of but will be ignored
42 # if these exist
43 rm -f "${S}/common/m4/pkg.m4"
44 rm -f "${S}/common/m4/gtk-doc.m4"
45}
46do_configure[prefuncs] += "delete_pkg_m4_file"
47
48set_omx_core_name() {
49 sed -i -e "s;^core-name=.*;core-name=${GSTREAMER_1_0_OMX_CORE_NAME};" "${D}${sysconfdir}/xdg/gstomx.conf"
50}
51do_install[postfuncs] += " set_omx_core_name "
52
53FILES_${PN} += "${libdir}/gstreamer-1.0/*.so"
54FILES_${PN}-dev += "${libdir}/gstreamer-1.0/*.la"
55FILES_${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a"
56
57RDEPENDS_${PN} = "libomxil"