summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gst-examples_1.18.6.bb
diff options
context:
space:
mode:
authorJose Quaresma <quaresma.jose@gmail.com>2022-02-19 20:15:14 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-02 00:22:13 +0000
commit012a08a95c475b6367e6f8a5d32e1b7de37ec098 (patch)
tree101cb2c24e41859acdae36e2d68ca9aba3441181 /meta/recipes-multimedia/gstreamer/gst-examples_1.18.6.bb
parent0ee5dc8a32c459084608aea93b240fb9ff298cf5 (diff)
downloadpoky-012a08a95c475b6367e6f8a5d32e1b7de37ec098.tar.gz
gst-examples: 1.18.5 -> 1.18.6
(From OE-Core rev: f72a3ab5455df01610d643de55e00dd53de272f7) Signed-off-by: Jose Quaresma <quaresma.jose@gmail.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gst-examples_1.18.6.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gst-examples_1.18.6.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gst-examples_1.18.6.bb b/meta/recipes-multimedia/gstreamer/gst-examples_1.18.6.bb
new file mode 100644
index 0000000000..5af43d1eda
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gst-examples_1.18.6.bb
@@ -0,0 +1,35 @@
1SUMMARY = "GStreamer examples (including gtk-play, gst-play)"
2DESCRIPTION = "GStreamer example applications"
3HOMEPAGE = "https://gitlab.freedesktop.org/gstreamer/gst-examples"
4BUGTRACKER = "https://gitlab.freedesktop.org/gstreamer/gst-examples/-/issues"
5LICENSE = "LGPL-2.0+"
6LIC_FILES_CHKSUM = "file://playback/player/gtk/gtk-play.c;beginline=1;endline=20;md5=f8c72dae3d36823ec716a9ebcae593b9"
7
8DEPENDS = "glib-2.0 gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad gtk+3 libsoup-2.4 json-glib glib-2.0-native"
9
10SRC_URI = "git://gitlab.freedesktop.org/gstreamer/gst-examples.git;protocol=https;branch=1.18 \
11 file://0001-Make-player-examples-installable.patch \
12 file://gst-player.desktop \
13 "
14
15SRCREV = "70e4fcf4fc8ae19641aa990de5f37d758cdfcea4"
16
17S = "${WORKDIR}/git"
18
19inherit meson pkgconfig features_check
20
21UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+\.(\d*[02468])+(\.\d+)+)"
22
23ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
24
25do_install_append() {
26 install -m 0644 -D ${WORKDIR}/gst-player.desktop ${D}${datadir}/applications/gst-player.desktop
27}
28
29RDEPENDS_${PN} = "gstreamer1.0-plugins-base-playback"
30RRECOMMENDS_${PN} = "gstreamer1.0-plugins-base-meta \
31 gstreamer1.0-plugins-good-meta \
32 gstreamer1.0-plugins-bad-meta \
33 ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "gstreamer1.0-libav", "", d)} \
34 ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "gstreamer1.0-plugins-ugly-meta", "", d)}"
35RPROVIDES_${PN} += "gst-player gst-player-bin"