summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gst-devtools_1.20.4.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2022-12-21 19:05:56 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-12-22 23:05:50 +0000
commit31d920465a0e166b631964d309eb4ff1ae9b1c9d (patch)
treeb5366a7741ea9d39aaebf3968ab03dc2adbe01bf /meta/recipes-multimedia/gstreamer/gst-devtools_1.20.4.bb
parent603519513aaf7b8f295050d863994d7c7da42c46 (diff)
downloadpoky-31d920465a0e166b631964d309eb4ff1ae9b1c9d.tar.gz
gstreamer1.0: upgrade 1.20.4 -> 1.20.5
Changelog: =========== systemclock waiting fixes for certain 32-bit platforms/libcs alphacombine: robustness improvements for corner case scenarios avfvideosrc: Report latency when doing screen capture d3d11videosink: various thread-safety and stability fixes decklink: fix performance issue when HDMI signal has been lost for a long time flacparse: Fix handling of headers advertising 32 bits per sample mpegts: Handle when iconv doesn't support ISO 6937 (e.g. musl libc) opengl: fix automatic dispmanx detection for rpi4 and fix usage of eglCreate/DestroyImage opusdec: Various channel-related fixes textrender: event handling fixes, esp. for GAP event subparse: Fix non-closed tag handling videoscale: fix handling of unknown buffer metas videosink: reverse playback handling fixes qtmux: Prefill mode fixes, especially for raw audio multiudpsink: allow binding to IPv6 address rtspsrc: Fix usage of IPv6 connections in SETUP rtspsrc: Only EOS on timeout if all streams are timed out/EOS splitmuxsrc: fix playback stall if there are unlinked pads v4l2: Fix SIGSEGV on state change during format changes wavparse robustness fixes Fix static linking on macOS (opengl, vulkan) gstreamer-vaapi: fix headless build against mesa >= 22.3.0 GStreamer Editing Services library: Fix build with tools disabled webrtc example/demo fixes unit test fixes for aesdec and rtpjitterbuffer Cerbero: Fix ios cross-compile with cmake on M1; some recipe updates and other build fixes Binary packages: pkg-config file fixes for various recipes (ffmpeg, taglib, gstreamer) Binary packages: Enable high bitdepth support for libvpx (VP8/VP9 encoding/decoding) Binary packages: ship aes plugin Miscellaneous bug fixes, memory leak fixes, and other stability and reliability improvements Performance improvements (From OE-Core rev: fd8ab6052d88120c58cf84ad7d77d60c12ef3b8a) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gst-devtools_1.20.4.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gst-devtools_1.20.4.bb52
1 files changed, 0 insertions, 52 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gst-devtools_1.20.4.bb b/meta/recipes-multimedia/gstreamer/gst-devtools_1.20.4.bb
deleted file mode 100644
index 09b6e5a497..0000000000
--- a/meta/recipes-multimedia/gstreamer/gst-devtools_1.20.4.bb
+++ /dev/null
@@ -1,52 +0,0 @@
1SUMMARY = "Gstreamer validation tool"
2DESCRIPTION = "A Tool to test GStreamer components"
3HOMEPAGE = "https://gstreamer.freedesktop.org/documentation/gst-devtools/index.html"
4SECTION = "multimedia"
5
6LICENSE = "LGPL-2.1-or-later"
7LIC_FILES_CHKSUM = "file://validate/COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343"
8
9#S = "${WORKDIR}/gst-devtools-${PV}"
10
11SRC_URI = "https://gstreamer.freedesktop.org/src/gst-devtools/gst-devtools-${PV}.tar.xz \
12 file://0001-connect-has-a-different-signature-on-musl.patch \
13 "
14
15SRC_URI[sha256sum] = "82a293600273f4dd3eed567aae510ca0c7d629c3807788b00e6cdbd1d2459a84"
16
17DEPENDS = "json-glib glib-2.0 glib-2.0-native gstreamer1.0 gstreamer1.0-plugins-base"
18RRECOMMENDS:${PN} = "git"
19
20FILES:${PN} += "${datadir}/gstreamer-1.0/* ${libdir}/gst-validate-launcher/* ${libdir}/gstreamer-1.0/*"
21
22inherit meson pkgconfig gettext upstream-version-is-even gobject-introspection
23
24# TODO: put this in a gettext.bbclass patch
25def gettext_oemeson(d):
26 if d.getVar('USE_NLS') == 'no':
27 return '-Dnls=disabled'
28 # Remove the NLS bits if USE_NLS is no or INHIBIT_DEFAULT_DEPS is set
29 if d.getVar('INHIBIT_DEFAULT_DEPS') and not oe.utils.inherits(d, 'cross-canadian'):
30 return '-Dnls=disabled'
31 return '-Dnls=enabled'
32
33# Build GstValidateVideo
34PACKAGECONFIG[cairo] = "-Dcairo=enabled,-Dcairo=disabled,cairo"
35
36EXTRA_OEMESON += " \
37 -Ddoc=disabled \
38 -Ddebug_viewer=disabled \
39 -Dtests=disabled \
40 -Dvalidate=enabled \
41 ${@gettext_oemeson(d)} \
42"
43
44do_install:append () {
45 for fn in ${bindir}/gst-validate-launcher \
46 ${libdir}/gst-validate-launcher/python/launcher/config.py; do
47 sed -i -e 's,${B},/usr/src/debug/${PN},g' -e 's,${S},/usr/src/debug/${PN},g' ${D}$fn
48 done
49}
50
51GIR_MESON_ENABLE_FLAG = "enabled"
52GIR_MESON_DISABLE_FLAG = "disabled"