summaryrefslogtreecommitdiffstats
path: root/meta/recipes-lsb4/libpng/libpng12_1.2.50.bb
diff options
context:
space:
mode:
authorKang Kai <kai.kang@windriver.com>2013-04-09 11:16:37 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-04-09 13:16:53 +0100
commitce4faa00ec53df5417689065fda855c50818a990 (patch)
tree0b71cee0909e3600ef25e5a4a8339bb76264f6ea /meta/recipes-lsb4/libpng/libpng12_1.2.50.bb
parentf720f8f3d24fe914aaa2e7f6db190118769abf63 (diff)
downloadpoky-ce4faa00ec53df5417689065fda855c50818a990.tar.gz
libpng12: rename libpng_1.2.50 to libpng12
As Mark's suggestion, rename libpng_1.2.50 to libpng12 that multi-versions libpng could coexist. We want to make sure we have both the old and new versions to meet LSB compliance (for people who have that enabled) as well as the new version for newer applications. And drop link files that conflict with higher version. [YOCTO #4221] (From OE-Core rev: fc626e6861e491b0144b813a5b48b0f5f57664e6) Signed-off-by: Kang Kai <kai.kang@windriver.com> CC: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-lsb4/libpng/libpng12_1.2.50.bb')
-rw-r--r--meta/recipes-lsb4/libpng/libpng12_1.2.50.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-lsb4/libpng/libpng12_1.2.50.bb b/meta/recipes-lsb4/libpng/libpng12_1.2.50.bb
new file mode 100644
index 0000000000..cfefd41beb
--- /dev/null
+++ b/meta/recipes-lsb4/libpng/libpng12_1.2.50.bb
@@ -0,0 +1,35 @@
1SUMMARY = "PNG Library"
2DESCRIPTION = "PNG Library"
3HOMEPAGE = "http://www.libpng.org/"
4SECTION = "libs"
5LICENSE = "Libpng"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=c3d807a85c09ebdff087f18b4969ff96 \
7 file://png.h;beginline=310;endline=424;md5=b87b5e9252a3e14808a27b92912d268d"
8DEPENDS = "zlib"
9PR = "r0"
10
11PN = "libpng12"
12S = "${WORKDIR}/libpng-${PV}"
13
14SRC_URI = "${SOURCEFORGE_MIRROR}/project/libpng/libpng12/${PV}/libpng-${PV}.tar.xz"
15
16SRC_URI[md5sum] = "a3e00fccbfe356174ab515b5c00641c7"
17SRC_URI[sha256sum] = "4724f81f8c92ac7f360ad1fbf173396ea7c535923424db9fbaff07bfd9d8e8e7"
18
19BINCONFIG_GLOB = "${PN}-config"
20
21inherit autotools binconfig pkgconfig
22
23do_install_append() {
24 # The follow link files link to corresponding png12*.h and libpng12* files
25 # They conflict with higher verison, so drop them
26 unlink ${D}/${includedir}/png.h
27 unlink ${D}/${includedir}/pngconf.h
28
29 unlink ${D}/${libdir}/libpng.la
30 unlink ${D}/${libdir}/libpng.so
31 unlink ${D}/${libdir}/libpng.a
32 unlink ${D}/${libdir}/pkgconfig/libpng.pc
33
34 unlink ${D}/${bindir}/libpng-config
35}