summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/systemtap/systemtap_git.bb
diff options
context:
space:
mode:
authorWade Farnsworth <wade_farnsworth@mentor.com>2012-02-06 07:49:14 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-02-08 00:50:24 +0000
commit98a994acff338bfcb886d55156d3acdaa52601b9 (patch)
treecc1a9dad3752090758a67e1e827b297b69bfed0a /meta/recipes-kernel/systemtap/systemtap_git.bb
parentc2c215b8879be45c367c7986825085789c9985ff (diff)
downloadpoky-98a994acff338bfcb886d55156d3acdaa52601b9.tar.gz
systemtap: build and install uprobes.ko
SystemTap needs to provide uprobes.ko in order to support user space probing. Build and install the module on systems that support it. Additionally, split off common bits into systemtap_git.inc. (From OE-Core rev: 3cc4ba935444240b93abdc726342658ada803118) Signed-off-by: Wade Farnsworth <wade_farnsworth@mentor.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/systemtap/systemtap_git.bb')
-rw-r--r--meta/recipes-kernel/systemtap/systemtap_git.bb18
1 files changed, 3 insertions, 15 deletions
diff --git a/meta/recipes-kernel/systemtap/systemtap_git.bb b/meta/recipes-kernel/systemtap/systemtap_git.bb
index fb3c0efaa2..c4a9d87dfd 100644
--- a/meta/recipes-kernel/systemtap/systemtap_git.bb
+++ b/meta/recipes-kernel/systemtap/systemtap_git.bb
@@ -1,16 +1,12 @@
1DESCRIPTION = "SystemTap - script-directed dynamic tracing and performance analysis tool for Linux" 1DESCRIPTION = "SystemTap - script-directed dynamic tracing and performance analysis tool for Linux"
2LICENSE = "GPLv2" 2
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" 3require systemtap_git.inc
4 4
5DEPENDS = "elfutils sqlite3 systemtap-native" 5DEPENDS = "elfutils sqlite3 systemtap-native"
6DEPENDS_virtclass-native = "elfutils-native sqlite3-native gettext-native" 6DEPENDS_virtclass-native = "elfutils-native sqlite3-native gettext-native"
7DEPENDS_virtclass-nativesdk = "elfutils-nativesdk sqlite3-nativesdk gettext-nativesdk" 7DEPENDS_virtclass-nativesdk = "elfutils-nativesdk sqlite3-nativesdk gettext-nativesdk"
8 8
9SRCREV = "83bd2699d8cff2f2d6b9eaf5ea254e4cb6b33e81" 9PR = "r2"
10PR = "r1"
11PV = "1.7+git${SRCPV}"
12
13SRC_URI = "git://sources.redhat.com/git/systemtap.git;protocol=git"
14 10
15EXTRA_OECONF += "--with-libelf=${STAGING_DIR_TARGET} --without-rpm \ 11EXTRA_OECONF += "--with-libelf=${STAGING_DIR_TARGET} --without-rpm \
16 ac_cv_file__usr_include_nss=no \ 12 ac_cv_file__usr_include_nss=no \
@@ -20,14 +16,6 @@ EXTRA_OECONF += "--with-libelf=${STAGING_DIR_TARGET} --without-rpm \
20 ac_cv_file__usr_include_avahi_client=no \ 16 ac_cv_file__usr_include_avahi_client=no \
21 ac_cv_file__usr_include_avahi_common=no " 17 ac_cv_file__usr_include_avahi_common=no "
22 18
23SRC_URI[md5sum] = "cb202866ed704c44a876d041f788bdee"
24SRC_URI[sha256sum] = "8ffe35caec0d937bd23fd78a3a8d94b58907cc0de0330b35e38f9f764815c459"
25
26# systemtap doesn't support mips
27COMPATIBLE_HOST = '(x86_64.*|i.86.*|powerpc.*|arm.*)-linux'
28
29S = "${WORKDIR}/git"
30
31inherit autotools gettext 19inherit autotools gettext
32 20
33BBCLASSEXTEND = "native nativesdk" 21BBCLASSEXTEND = "native nativesdk"