summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/powertop/powertop_2.9.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2017-10-12 17:41:47 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-11-05 22:33:21 +0000
commit2f5e7b0cd3f684a944d657631f7dca95df8611f0 (patch)
treee6fd10fbdb548869e3ef1e27d5e0be4d24995d7e /meta/recipes-kernel/powertop/powertop_2.9.bb
parent36ba73e495a3f4e75a1be813fb73b5ad27990784 (diff)
downloadpoky-2f5e7b0cd3f684a944d657631f7dca95df8611f0.tar.gz
powertop: update to v2.9
* Upstream filename added "v" before version: - Add UPSTREAM_CHECK_REGEX - Update SRC_URI to include the "v" - Point ${S} to proper directory * Patch for required headers no longer needed in current upstream * Tested on qemux86-64 core-image-full-cmdline image with multilib (From OE-Core rev: c12f7f7492c33134ad6dde65fe119d53301dca2f) Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/powertop/powertop_2.9.bb')
-rw-r--r--meta/recipes-kernel/powertop/powertop_2.9.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-kernel/powertop/powertop_2.9.bb b/meta/recipes-kernel/powertop/powertop_2.9.bb
new file mode 100644
index 0000000000..4fe5447a03
--- /dev/null
+++ b/meta/recipes-kernel/powertop/powertop_2.9.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Power usage tool"
2DESCRIPTION = "Linux tool to diagnose issues with power consumption and power management."
3HOMEPAGE = "http://01.org/powertop/"
4BUGTRACKER = "http://bugzilla.lesswatts.org/"
5DEPENDS = "ncurses libnl pciutils"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
8
9SRC_URI = "http://01.org/sites/default/files/downloads/powertop/powertop-v${PV}.tar.gz \
10"
11
12SRC_URI[md5sum] = "583518c5c4434c6e9b9c58c3920950b6"
13SRC_URI[sha256sum] = "aa7fb7d8e9a00f05e7d8a7a2866d85929741e0d03a5bf40cab22d2021c959250"
14
15UPSTREAM_CHECK_URI = "https://01.org/powertop/downloads"
16UPSTREAM_CHECK_REGEX = "powertop-[v]?(?P<pver>\d+(\.\d+)+)\.tar"
17
18inherit autotools gettext pkgconfig
19
20S = "${WORKDIR}/${BPN}-v${PV}"
21
22# we do not want libncursesw if we can
23do_configure_prepend() {
24 # configure.ac checks for delwin() in "ncursesw ncurses" so let's drop first one
25 sed -i -e "s/ncursesw//g" ${S}/configure.ac
26 mkdir -p ${B}/src/tuning/
27}
28
29inherit update-alternatives
30ALTERNATIVE_${PN} = "powertop"
31ALTERNATIVE_TARGET[powertop] = "${sbindir}/powertop"
32ALTERNATIVE_LINK_NAME[powertop] = "${sbindir}/powertop"
33ALTERNATIVE_PRIORITY = "100"