summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/powertop/powertop_2.8.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2015-12-14 16:07:04 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-16 12:12:18 +0000
commit0c705d6125dbd9ec481794dc5f879ea9be0cae81 (patch)
tree360fc8c46af6762347e41defc5c7c2c23714f6ba /meta/recipes-kernel/powertop/powertop_2.8.bb
parent516d8c9759d18952869e7b1045a0fcd880cca1bc (diff)
downloadpoky-0c705d6125dbd9ec481794dc5f879ea9be0cae81.tar.gz
powertop: update to 2.8
(From OE-Core rev: 7763b318e8c5f117aabe57e451879734ac2b81e4) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/powertop/powertop_2.8.bb')
-rw-r--r--meta/recipes-kernel/powertop/powertop_2.8.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-kernel/powertop/powertop_2.8.bb b/meta/recipes-kernel/powertop/powertop_2.8.bb
new file mode 100644
index 0000000000..a466067562
--- /dev/null
+++ b/meta/recipes-kernel/powertop/powertop_2.8.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Power usage tool"
2DESCRIPTION = "Linux tool to diagnose issues with power consumption and power management."
3HOMEPAGE = "http://01.org/powertop/"
4BUGTRACKER = "http://bugzilla.lesswatts.org/"
5DEPENDS = "ncurses libnl pciutils"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
8
9SRC_URI = "http://01.org/sites/default/files/downloads/powertop/powertop-${PV}.tar.gz"
10
11SRC_URI[md5sum] = "c55fedb69203e480801b18bd7b886241"
12SRC_URI[sha256sum] = "a87b563f73106babfa3e74dcf92f252938c061e309ace20a361358bbfa579c5a"
13
14UPSTREAM_CHECK_URI = "https://01.org/powertop/downloads"
15
16inherit autotools gettext pkgconfig
17
18# we need to explicitly link with libintl in uClibc systems
19EXTRA_LDFLAGS ?= ""
20EXTRA_LDFLAGS_libc-uclibc = "-lintl"
21LDFLAGS += "${EXTRA_LDFLAGS}"
22
23# we do not want libncursesw if we can
24do_configure_prepend() {
25 # configure.ac checks for delwin() in "ncursesw ncurses" so let's drop first one
26 sed -i -e "s/ncursesw//g" ${S}/configure.ac
27 mkdir -p ${B}/src/tuning/
28}
29
30inherit update-alternatives
31ALTERNATIVE_${PN} = "powertop"
32ALTERNATIVE_TARGET[powertop] = "${sbindir}/powertop"
33ALTERNATIVE_LINK_NAME[powertop] = "${sbindir}/powertop"
34ALTERNATIVE_PRIORITY = "100"