summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/powertop/powertop_2.3.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin.juszkiewicz@linaro.org>2013-04-11 16:05:14 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-04-22 14:45:04 +0100
commit7195096f5754245f2b495a1629c6eb5ae6427afe (patch)
tree9cb7874830ec94eddcfec5d28a3a6711a0308c50 /meta/recipes-kernel/powertop/powertop_2.3.bb
parent4178360b2ba645f3519d227e27c0beb80768d801 (diff)
downloadpoky-7195096f5754245f2b495a1629c6eb5ae6427afe.tar.gz
powertop: add 2.3
With all tweaks from 1.13: - uclibc buildable - libncurses instead of libncursesw Changes from v3: - proper update-alternatives path (From OE-Core rev: 188862de64bc2b61f8510082c8a6e5929d2b79d1) Signed-off-by: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/powertop/powertop_2.3.bb')
-rw-r--r--meta/recipes-kernel/powertop/powertop_2.3.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-kernel/powertop/powertop_2.3.bb b/meta/recipes-kernel/powertop/powertop_2.3.bb
new file mode 100644
index 0000000000..8d290d3a80
--- /dev/null
+++ b/meta/recipes-kernel/powertop/powertop_2.3.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Power usage tool"
2DESCRIPTION = "Linux tool to diagnose issues with power consumption and power management."
3HOMEPAGE = "http://01.org/powertop/"
4BUGTRACKER = "http://bugzilla.lesswatts.org/"
5DEPENDS = "ncurses virtual/gettext libnl pciutils"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
8
9SRC_URI = "http://01.org/powertop/sites/default/files/downloads/powertop-${PV}.tar.gz"
10
11SRC_URI[md5sum] = "dc03608f20e56cdc99d121a6191556f6"
12SRC_URI[sha256sum] = "b8c1add69afee28c77dca56fdcedb4a46820f3a71c86aae7891b0c5c595cd744"
13
14inherit autotools
15
16# we need to explicitly link with libintl in uClibc systems
17LDFLAGS += "${EXTRA_LDFLAGS}"
18EXTRA_LDFLAGS_libc-uclibc = "-lintl"
19
20# we do not want libncursesw if we can
21do_configure_prepend() {
22 # configure.ac checks for delwin() in "ncursesw ncurses" so let's drop first one
23 sed -i -e "s/ncursesw//g" ${S}/configure.ac
24}
25
26inherit update-alternatives
27ALTERNATIVE_${PN} = "powertop"
28ALTERNATIVE_TARGET[powertop] = "${sbindir}/powertop"
29ALTERNATIVE_LINK_NAME[powertop] = "${base_bindir}/powertop"
30ALTERNATIVE_PRIORITY = "100"