summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/powertop/powertop_2.13.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@cn.fujitsu.com>2020-06-17 13:39:00 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-06-23 12:31:02 +0100
commit89bf9f6e61aae97f8c7876ec38b362f841e0374a (patch)
tree9e7e25419be26f7dd3efc62f02c02febddbcd552 /meta/recipes-kernel/powertop/powertop_2.13.bb
parent59ac1777ce32b75299ab42d634db560ac001686a (diff)
downloadpoky-89bf9f6e61aae97f8c7876ec38b362f841e0374a.tar.gz
powertop: upgrade 2.12 -> 2.13
?Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com> (From OE-Core rev: 0d8fd1d44c932073021ef0786e40e43f4f1e330b) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/powertop/powertop_2.13.bb')
-rw-r--r--meta/recipes-kernel/powertop/powertop_2.13.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-kernel/powertop/powertop_2.13.bb b/meta/recipes-kernel/powertop/powertop_2.13.bb
new file mode 100644
index 0000000000..8c7e78fd94
--- /dev/null
+++ b/meta/recipes-kernel/powertop/powertop_2.13.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Power usage tool"
2DESCRIPTION = "Linux tool to diagnose issues with power consumption and power management."
3HOMEPAGE = "https://01.org/powertop/"
4BUGTRACKER = "https://app.devzing.com/powertopbugs/bugzilla"
5DEPENDS = "ncurses libnl pciutils autoconf-archive"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
8
9SRC_URI = "git://github.com/fenrus75/powertop;protocol=https \
10 file://0001-wakeup_xxx.h-include-limits.h.patch \
11"
12SRCREV = "184cee06b2d64679bae5f806fe0a218827fdde99"
13
14S = "${WORKDIR}/git"
15
16inherit autotools gettext pkgconfig bash-completion
17
18# we do not want libncursesw if we can
19do_configure_prepend() {
20 # configure.ac checks for delwin() in "ncursesw ncurses" so let's drop first one
21 sed -i -e "s/ncursesw//g" ${S}/configure.ac
22 mkdir -p ${B}/src/tuning/
23 echo "${PV}" > ${S}/version-long
24 echo "${PV}" > ${S}/version-short
25 cp ${STAGING_DATADIR}/aclocal/ax_require_defined.m4 ${S}/m4/
26}
27
28inherit update-alternatives
29ALTERNATIVE_${PN} = "powertop"
30ALTERNATIVE_TARGET[powertop] = "${sbindir}/powertop"
31ALTERNATIVE_LINK_NAME[powertop] = "${sbindir}/powertop"
32ALTERNATIVE_PRIORITY = "100"