summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-ust_2.10.4.bb
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2019-06-19 15:14:40 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-06-19 22:13:39 +0100
commit1c7546e372236e467a0a49bbc9fc39f7b985922c (patch)
tree50ab6c8d545c57e9b515e7e349d4e64154233919 /meta/recipes-kernel/lttng/lttng-ust_2.10.4.bb
parentca0eeb5c3689376f43055e0c4fb316199acc59e3 (diff)
downloadpoky-1c7546e372236e467a0a49bbc9fc39f7b985922c.tar.gz
lttng-ust:upgrade 2.10.3 -> 2.10.4
-Upgrade from lttng-ust_2.10.3.bb to lttng-ust_2.10.4.bb. -lttng-ust/0001-compat-work-around-broken-_SC_NPROCESSORS_CONF-on-MU.patch Removed since this is included in 2.10.4 (From OE-Core rev: dc25e9525495e00940da7716cbba6bca96423acd) Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-ust_2.10.4.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-ust_2.10.4.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-ust_2.10.4.bb b/meta/recipes-kernel/lttng/lttng-ust_2.10.4.bb
new file mode 100644
index 0000000000..a8eebb223b
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-ust_2.10.4.bb
@@ -0,0 +1,48 @@
1SUMMARY = "Linux Trace Toolkit Userspace Tracer 2.x"
2DESCRIPTION = "The LTTng UST 2.x package contains the userspace tracer library to trace userspace codes."
3HOMEPAGE = "http://lttng.org/ust"
4BUGTRACKER = "https://bugs.lttng.org/projects/lttng-ust"
5
6LICENSE = "LGPLv2.1+ & MIT & GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=c963eb366b781252b0bf0fdf1624d9e9 \
8 file://snprintf/snprintf.c;endline=32;md5=d3d544959d8a3782b2e07451be0a903c \
9 file://snprintf/various.h;endline=31;md5=89f2509b6b4682c4fc95255eec4abe44"
10
11PYTHON_OPTION = "am_cv_python_pyexecdir='${PYTHON_SITEPACKAGES_DIR}' \
12 am_cv_python_pythondir='${PYTHON_SITEPACKAGES_DIR}' \
13 PYTHON_INCLUDE='-I${STAGING_INCDIR}/python${PYTHON_BASEVERSION}${PYTHON_ABI}' \
14"
15
16inherit autotools lib_package manpages python3native
17
18DEPENDS = "liburcu util-linux"
19RDEPENDS_${PN}-bin = "python3-core"
20
21# For backwards compatibility after rename
22RPROVIDES_${PN} = "lttng2-ust"
23RREPLACES_${PN} = "lttng2-ust"
24RCONFLICTS_${PN} = "lttng2-ust"
25
26PE = "2"
27
28SRC_URI = "https://lttng.org/files/lttng-ust/lttng-ust-${PV}.tar.bz2 \
29 file://lttng-ust-doc-examples-disable.patch \
30 "
31
32SRC_URI[md5sum] = "19916ff0dec23c90f985586a8cbd1fd2"
33SRC_URI[sha256sum] = "75d5b4bb205c444a343e1297e14cd3a2503fc645a26710531cbd319c72c1a967"
34
35CVE_PRODUCT = "ust"
36
37PACKAGECONFIG[manpages] = "--enable-man-pages, --disable-man-pages, asciidoc-native xmlto-native libxslt-native"
38PACKAGECONFIG[python3-agent] = "--enable-python-agent ${PYTHON_OPTION}, --disable-python-agent, python3, python3"
39
40FILES_${PN} += " ${PYTHON_SITEPACKAGES_DIR}/*"
41FILES_${PN}-staticdev += " ${PYTHON_SITEPACKAGES_DIR}/*.a"
42FILES_${PN}-dev += " ${PYTHON_SITEPACKAGES_DIR}/*.la"
43
44do_install_append() {
45 # Patch python tools to use Python 3; they should be source compatible, but
46 # still refer to Python 2 in the shebang
47 sed -i -e '1s,#!.*python.*,#!${bindir}/python3,' ${D}${bindir}/lttng-gen-tp
48}