summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-modules_git.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-07-13 19:44:11 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-20 10:40:42 +0100
commite9b9f8c0c5a208c02453839442099527fe6b13de (patch)
tree9de27c37e96682f9606355c2cd43710fac57b8fc /meta/recipes-kernel/lttng/lttng-modules_git.bb
parent8325277c76551d92013cb528a3d0e612c71b2759 (diff)
downloadpoky-e9b9f8c0c5a208c02453839442099527fe6b13de.tar.gz
lttng-modules: 2.6.1 -> 2.6.2
* Rename recipe name from lttng-modules_2.6.1.bb to lttng-modules_git.bb (From OE-Core rev: 180ce6570ba133ec5f36de3288d6ec163b54eefe) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_git.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_git.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_git.bb b/meta/recipes-kernel/lttng/lttng-modules_git.bb
new file mode 100644
index 0000000000..54544fee09
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-modules_git.bb
@@ -0,0 +1,33 @@
1SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4LICENSE = "LGPLv2.1 & GPLv2 & MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1412caf5a1aa90d6a48588a4794c0eac \
6 file://gpl-2.0.txt;md5=751419260aa954499f7abaabaa882bbe \
7 file://lgpl-2.1.txt;md5=243b725d71bb5df4a1e5920b344b86ad"
8
9inherit module
10
11SRCREV = "7a88f8b50696dd71e80c08661159caf8e119bf51"
12PV = "2.6.2+git${SRCPV}"
13
14COMPATIBLE_HOST = '(x86_64|i.86|powerpc|aarch64|mips|arm).*-linux'
15
16SRC_URI = "git://git.lttng.org/lttng-modules.git;branch=stable-2.6"
17
18export INSTALL_MOD_DIR="kernel/lttng-modules"
19
20EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
21
22S = "${WORKDIR}/git"
23
24do_install_append() {
25 # Delete empty directories to avoid QA failures if no modules were built
26 find ${D}/lib -depth -type d -empty -exec rmdir {} \;
27}
28
29python do_package_prepend() {
30 if not os.path.exists(os.path.join(d.getVar('D', True), 'lib/modules')):
31 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN', True))
32}
33