summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-modules_git.bb
diff options
context:
space:
mode:
authorEmilia Ciobanu <emilia.maria.silvia.ciobanu@intel.com>2013-07-08 16:37:23 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-07-24 11:35:32 +0100
commitba0640a13c88a8aaf5b383e793d02c1f7f08e80a (patch)
treec562464015616b1373982db515e6cfc7d37de950 /meta/recipes-kernel/lttng/lttng-modules_git.bb
parent3c0300ba86998d5a296299c5769ca2e8a04d6007 (diff)
downloadpoky-ba0640a13c88a8aaf5b383e793d02c1f7f08e80a.tar.gz
lttng-modules: Append _git to recipe name and add GIT revision to PV variable
Git packages should have the following format for the PV variable: version_tag+git[r|\-|]?AUTOINC+git_revision (From OE-Core rev: 07ca5da4da59a0069e7b8a18e7589e3674f2616c) Signed-off-by: Emilia Ciobanu <emilia.maria.silvia.ciobanu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_git.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_git.bb b/meta/recipes-kernel/lttng/lttng-modules_git.bb
new file mode 100644
index 0000000000..3a92879e3c
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-modules_git.bb
@@ -0,0 +1,34 @@
1SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4LICENSE = "LGPLv2.1 & GPLv2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1412caf5a1aa90d6a48588a4794c0eac \
6 file://gpl-2.0.txt;md5=751419260aa954499f7abaabaa882bbe \
7 file://lgpl-2.1.txt;md5=243b725d71bb5df4a1e5920b344b86ad"
8
9DEPENDS = "virtual/kernel"
10
11inherit module
12
13SRCREV = "1b26381c19dd2d9fa41f52d8dc13b15b8dd32c7c"
14PV = "2.2.0+git${SRCPV}"
15
16SRC_URI = "git://git.lttng.org/lttng-modules.git;protocol=git \
17 file://lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch"
18
19export INSTALL_MOD_DIR="kernel/lttng-modules"
20export KERNEL_SRC="${STAGING_KERNEL_DIR}"
21
22
23S = "${WORKDIR}/git"
24
25do_install_append() {
26 # Delete empty directories to avoid QA failures if no modules were built
27 find ${D}/lib -depth -type d -empty -exec rmdir {} \;
28}
29
30python do_package_prepend() {
31 if not os.path.exists(os.path.join(d.getVar('D', True), 'lib/modules')):
32 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN', True))
33}
34