summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-modules_git.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2013-11-14 15:43:49 -0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-11-20 14:03:27 +0000
commit8d2b5f3c20092e90807cf50c1a633e31e0ee81e9 (patch)
tree89f8e9ef9f63967df7a944a506b78f015e5b05f1 /meta/recipes-kernel/lttng/lttng-modules_git.bb
parent7ef7e55180a9164bea860ab626d02a5df75f1727 (diff)
downloadpoky-8d2b5f3c20092e90807cf50c1a633e31e0ee81e9.tar.gz
lttng-modules: Update to 2.3.3 version
This updates lttng-modules for 2.3.3 and it also fixes the build with 3.12 Linux kernel. While on that, we also renamed the recipe file to follow the other lttng recipes which use the version number on it. (From OE-Core rev: 2d01bd48e689656bbe6189243d077f822092a14a) Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_git.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_git.bb34
1 files changed, 0 insertions, 34 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_git.bb b/meta/recipes-kernel/lttng/lttng-modules_git.bb
deleted file mode 100644
index 789b5ec94f..0000000000
--- a/meta/recipes-kernel/lttng/lttng-modules_git.bb
+++ /dev/null
@@ -1,34 +0,0 @@
1SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4LICENSE = "LGPLv2.1 & GPLv2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1412caf5a1aa90d6a48588a4794c0eac \
6 file://gpl-2.0.txt;md5=751419260aa954499f7abaabaa882bbe \
7 file://lgpl-2.1.txt;md5=243b725d71bb5df4a1e5920b344b86ad"
8
9DEPENDS = "virtual/kernel"
10
11inherit module
12
13SRCREV = "78c8710bb8e6b7f6301d95afec0305f40fa063ad"
14PV = "2.3.0+git${SRCPV}"
15
16SRC_URI = "git://git.lttng.org/lttng-modules.git \
17 file://lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch"
18
19export INSTALL_MOD_DIR="kernel/lttng-modules"
20export KERNEL_SRC="${STAGING_KERNEL_DIR}"
21
22
23S = "${WORKDIR}/git"
24
25do_install_append() {
26 # Delete empty directories to avoid QA failures if no modules were built
27 find ${D}/lib -depth -type d -empty -exec rmdir {} \;
28}
29
30python do_package_prepend() {
31 if not os.path.exists(os.path.join(d.getVar('D', True), 'lib/modules')):
32 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN', True))
33}
34