summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-modules_2.3.3.bb
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2014-06-26 14:36:22 +0200
committerAdrian Dudau <adrian.dudau@enea.com>2014-06-26 15:32:53 +0200
commitf4cf9fe05bb3f32fabea4e54dd92d368967a80da (patch)
tree487180fa9866985ea7b28e625651765d86f515c3 /meta/recipes-kernel/lttng/lttng-modules_2.3.3.bb
downloadpoky-f4cf9fe05bb3f32fabea4e54dd92d368967a80da.tar.gz
initial commit for Enea Linux 4.0
Migrated from the internal git server on the daisy-enea branch Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_2.3.3.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.3.3.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.3.3.bb b/meta/recipes-kernel/lttng/lttng-modules_2.3.3.bb
new file mode 100644
index 0000000000..4f18ddc367
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.3.3.bb
@@ -0,0 +1,35 @@
1SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4LICENSE = "LGPLv2.1 & GPLv2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1412caf5a1aa90d6a48588a4794c0eac \
6 file://gpl-2.0.txt;md5=751419260aa954499f7abaabaa882bbe \
7 file://lgpl-2.1.txt;md5=243b725d71bb5df4a1e5920b344b86ad"
8
9DEPENDS = "virtual/kernel"
10
11inherit module
12
13SRCREV = "eef112db0e63feff6cbf0a98cda9af607cefb377"
14PV = "2.3.3"
15
16SRC_URI = "git://git.lttng.org/lttng-modules.git;branch=stable-2.3 \
17 file://lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch \
18 file://bio-bvec-iter.patch"
19
20export INSTALL_MOD_DIR="kernel/lttng-modules"
21export KERNEL_SRC="${STAGING_KERNEL_DIR}"
22
23
24S = "${WORKDIR}/git"
25
26do_install_append() {
27 # Delete empty directories to avoid QA failures if no modules were built
28 find ${D}/lib -depth -type d -empty -exec rmdir {} \;
29}
30
31python do_package_prepend() {
32 if not os.path.exists(os.path.join(d.getVar('D', True), 'lib/modules')):
33 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN', True))
34}
35