summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-modules_2.12.8.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2022-03-31 16:30:24 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-04-03 20:49:03 +0100
commita07b68e69b132891ec9b395b8ec6dbdb76af6ee7 (patch)
treeb7263aa1e0e321bf0e29363842a7774d4058a7f3 /meta/recipes-kernel/lttng/lttng-modules_2.12.8.bb
parente5870b84fb2faaffb9c2029dba9982f4f5f566e7 (diff)
downloadpoky-a07b68e69b132891ec9b395b8ec6dbdb76af6ee7.tar.gz
lttng-modules: upgrade 2.12.7 -> 2.12.8
(From OE-Core rev: 4011526ad7b2c8711038c1729c7fd046cf852ffb) Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_2.12.8.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.12.8.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.12.8.bb b/meta/recipes-kernel/lttng/lttng-modules_2.12.8.bb
new file mode 100644
index 0000000000..eff97f27af
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.12.8.bb
@@ -0,0 +1,42 @@
1SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4HOMEPAGE = "https://lttng.org/"
5LICENSE = "LGPLv2.1 & GPLv2 & MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=3f882d431dc0f32f1f44c0707aa41128"
7
8inherit module
9
10include lttng-platforms.inc
11
12SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
13 file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \
14 "
15
16SRC_URI[sha256sum] = "1302005a982fd4a15cc4843866971008546939f65660023d7762aa046d4b9213"
17
18export INSTALL_MOD_DIR="kernel/lttng-modules"
19
20EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
21
22do_install_append() {
23 # Delete empty directories to avoid QA failures if no modules were built
24 find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
25}
26
27python do_package_prepend() {
28 if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')):
29 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN'))
30}
31
32BBCLASSEXTEND = "devupstream:target"
33LIC_FILES_CHKSUM_class-devupstream = "file://LICENSE;md5=3f882d431dc0f32f1f44c0707aa41128"
34DEFAULT_PREFERENCE_class-devupstream = "-1"
35SRC_URI_class-devupstream = "git://git.lttng.org/lttng-modules;branch=stable-2.12 \
36 file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \
37 "
38
39SRCREV_class-devupstream = "92cc3e7f76a545a2cd4828576971f1eea83f4e68"
40PV_class-devupstream = "2.12.5+git${SRCPV}"
41S_class-devupstream = "${WORKDIR}/git"
42SRCREV_FORMAT ?= "lttng_git"