summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-modules_2.12.7.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2022-03-07 15:44:41 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-10 16:39:45 +0000
commit9af3064f014b6f1a97dec3f5f9370c14697fc621 (patch)
tree259d21708f207715042ff178801befad7d1bfd08 /meta/recipes-kernel/lttng/lttng-modules_2.12.7.bb
parent8fc32ee149727c2c20c8fa26ef2620f31c0e6e96 (diff)
downloadpoky-9af3064f014b6f1a97dec3f5f9370c14697fc621.tar.gz
lttng-modules: upgrade 2.12.6 -> 2.12.7
Changelog: * fix: mm: move kvmalloc-related functions to slab.h (v5.16) * fix: block: don't call blk_status_to_errno in blk_update_request (v5.16) * fix: KVM: MMU: change tracepoints arguments to kvm_page_fault (v5.16) * fix: KVM: x86: Get exit_reason as part of kvm_x86_ops.get_exit_info (v5.16) * fix: isystem: delete global -isystem compile option (v5.16) * fix: block: move block-related definitions out of fs.h (v5.16) * fix: implicit-int error in EXPORT_SYMBOL_GPL * fix: Revert "Makefile: Enable -Wimplicit-fallthrough for Clang" (v5.15) * fix: cpu/hotplug: Remove deprecated CPU-hotplug functions. (v5.15) * fix: sched: Change task_struct::state (v5.14) * fix: btrfs: pass btrfs_inode to btrfs_writepage_endio_finish_ordered() (v5.14) * fix: adjust ranges for RHEL 8.4 (From OE-Core rev: a5bade232676ffe282f2058eedfc20cfc19bf036) Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_2.12.7.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.12.7.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.12.7.bb b/meta/recipes-kernel/lttng/lttng-modules_2.12.7.bb
new file mode 100644
index 0000000000..5eb3902bb3
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.12.7.bb
@@ -0,0 +1,42 @@
1SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4HOMEPAGE = "https://lttng.org/"
5LICENSE = "LGPLv2.1 & GPLv2 & MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=3f882d431dc0f32f1f44c0707aa41128"
7
8inherit module
9
10include lttng-platforms.inc
11
12SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
13 file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \
14 "
15
16SRC_URI[sha256sum] = "32ab2d17d513cd2f458f8844c66a0d013283301fc7329b55d6503153cf8cb253"
17
18export INSTALL_MOD_DIR="kernel/lttng-modules"
19
20EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
21
22do_install_append() {
23 # Delete empty directories to avoid QA failures if no modules were built
24 find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
25}
26
27python do_package_prepend() {
28 if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')):
29 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN'))
30}
31
32BBCLASSEXTEND = "devupstream:target"
33LIC_FILES_CHKSUM_class-devupstream = "file://LICENSE;md5=3f882d431dc0f32f1f44c0707aa41128"
34DEFAULT_PREFERENCE_class-devupstream = "-1"
35SRC_URI_class-devupstream = "git://git.lttng.org/lttng-modules;branch=stable-2.12 \
36 file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \
37 "
38
39SRCREV_class-devupstream = "92cc3e7f76a545a2cd4828576971f1eea83f4e68"
40PV_class-devupstream = "2.12.5+git${SRCPV}"
41S_class-devupstream = "${WORKDIR}/git"
42SRCREV_FORMAT ?= "lttng_git"