summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/babeltrace2_2.0.6.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-04-09 15:09:48 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-04-16 08:07:02 +0100
commita79707b94dc35581152ac1457ec20752db694968 (patch)
tree65a3844c69e0c362dadef56183db98885d5a9d28 /meta/recipes-kernel/lttng/babeltrace2_2.0.6.bb
parentebf8852175637c5f15e3371d1b5e743ad96d91ff (diff)
downloadpoky-a79707b94dc35581152ac1457ec20752db694968.tar.gz
babeltrace2: upgrade 2.0.5 -> 2.0.6
Changelog: =========== * bt2: disable some warnings for 'native_bt.c' * bt2: compile 'native_bt.c' with '-Wno-undef' * Fix: src.ctf.lttng-live: expect NEW_STREAM/METADATA for inactive streams * Fix: 'babeltrace2 convert': don't consider the '--plugin-path' opt. * include/babeltrace2/plugin/plugin-dev.h: "define" -> "definition * Fix: doc: escape double quote in bt_p alias * Fix: bt2: pass _TraceClassConst to destruction listeners * fix: 'load_module()' deprecated in Python 3.12 * tests: retry os.rename on PermissionError failure in lttng_live_server.py * doc: fix uptream -> upstream typos * fix: test_message_iterator.py hangs on Python 3.12 * plugin-dev: mark symbols meant to be public with __attribute__((visibility("default"))) * Silence -Wunused-but-set-variable error with clang * Fix: Windows DLL path lookup with Python >= 3.8 * doc/man: make default values of boolean init. params. clearer * RFC: docs: fix: Match stated automake requirement * fix: make flake8 6.x happy * fix: running black on python 3.11 * bt_query_executor_create_with_method_data(): fix docs note * Fix: ctf-writer: null dereference in bt_ctf_trace_common_add_stream_class * Update working version to Babeltrace v2.0.6 (From OE-Core rev: a5f05da60ca888456900f9fb0a52ef07db754c06) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/lttng/babeltrace2_2.0.6.bb')
-rw-r--r--meta/recipes-kernel/lttng/babeltrace2_2.0.6.bb95
1 files changed, 95 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/babeltrace2_2.0.6.bb b/meta/recipes-kernel/lttng/babeltrace2_2.0.6.bb
new file mode 100644
index 0000000000..d6c75d7580
--- /dev/null
+++ b/meta/recipes-kernel/lttng/babeltrace2_2.0.6.bb
@@ -0,0 +1,95 @@
1SUMMARY = "Babeltrace2 - Trace Format Babel Tower"
2DESCRIPTION = "Babeltrace provides trace read and write libraries in host side, as well as a trace converter, which used to convert LTTng 2.0 traces into human-readable log."
3HOMEPAGE = "http://babeltrace.org/"
4BUGTRACKER = "https://bugs.lttng.org/projects/babeltrace"
5LICENSE = "MIT & GPL-2.0-only & LGPL-2.1-only & BSD-2-Clause"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=a6a458c13f18385b7bc5069a6d7b176e"
7
8DEPENDS = "glib-2.0 util-linux popt bison-native flex-native"
9
10SRC_URI = "git://git.efficios.com/babeltrace.git;branch=stable-2.0;protocol=https \
11 file://run-ptest \
12 file://0001-tests-do-not-run-test-applications-from-.libs.patch \
13 file://0001-Make-manpages-multilib-identical.patch \
14 "
15SRCREV = "0a6632f77801f3218a288604c646f8a39cb0d2c4"
16UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>2(\.\d+)+)$"
17
18S = "${WORKDIR}/git"
19
20inherit autotools pkgconfig ptest python3targetconfig
21
22EXTRA_OECONF = "--disable-debug-info --disable-Werror"
23
24PACKAGECONFIG ??= "manpages"
25PACKAGECONFIG[manpages] = ", --disable-man-pages, asciidoc-native xmlto-native"
26
27FILES:${PN}-staticdev += "${libdir}/babeltrace2/plugins/*.a"
28FILES:${PN} += "${libdir}/babeltrace2/plugins/*.so"
29
30ASNEEDED = ""
31LDFLAGS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-lld ptest', ' -fuse-ld=bfd ', '', d)}"
32
33# coreutils since we need full mktemp
34RDEPENDS:${PN}-ptest += "bash gawk python3 make grep coreutils findutils"
35
36do_compile_ptest () {
37 make -C tests all
38}
39
40do_install_ptest () {
41 install -d "${D}${PTEST_PATH}/tests"
42
43 # Copy required files from source directory
44 for d in $(find "${S}/tests" -type d -printf '%P ') ; do
45 install -d "${D}${PTEST_PATH}/tests/$d"
46 find "${S}/tests/$d" -maxdepth 1 -executable -type f \
47 -exec install -t "${D}${PTEST_PATH}/tests/$d" {} +
48 find "${S}/tests/$d" -maxdepth 1 -name *.sh \
49 -exec install -t "${D}${PTEST_PATH}/tests/$d" {} \;
50 find "${S}/tests/$d" -maxdepth 1 -name *.py \
51 -exec install -t "${D}${PTEST_PATH}/tests/$d" {} \;
52 find "${S}/tests/$d" -maxdepth 1 -name *.expect \
53 -exec install -t "${D}${PTEST_PATH}/tests/$d" {} \;
54 done
55 install -d "${D}${PTEST_PATH}/tests/data/ctf-traces/"
56 cp -a ${S}/tests/data/ctf-traces/* ${D}${PTEST_PATH}/tests/data/ctf-traces/
57
58 # Copy the tests directory tree and the executables and
59 # Makefiles found within.
60 install -D "${B}/tests/Makefile" "${D}${PTEST_PATH}/tests/"
61 for d in $(find "${B}/tests" -type d -not -name .libs -printf '%P ') ; do
62 install -d "${D}${PTEST_PATH}/tests/$d"
63 find "${B}/tests/$d" -maxdepth 1 -executable -type f \
64 -exec install -t "${D}${PTEST_PATH}/tests/$d" {} +
65 test -r "${B}/tests/$d/Makefile" && \
66 install -t "${D}${PTEST_PATH}/tests/$d" "${B}/tests/$d/Makefile"
67 find "${B}/tests/$d" -maxdepth 1 -name *.sh \
68 -exec install -t "${D}${PTEST_PATH}/tests/$d" {} \;
69 done
70
71 for d in $(find "${B}/tests" -type d -name .libs -printf '%P ') ; do
72 for f in $(find "${B}/tests/$d" -maxdepth 1 -executable -type f -printf '%P ') ; do
73 cp ${B}/tests/$d/$f ${D}${PTEST_PATH}/tests/`dirname $d`/$f
74 done
75 done
76
77 # Prevent attempts to update Makefiles during test runs, and
78 # silence "Making check in $SUBDIR" messages.
79 find "${D}${PTEST_PATH}" -name Makefile -type f -exec \
80 sed -i \
81 -e '/Makefile:/,/^$/d' \
82 -e '/%: %.in/,/^$/d' \
83 -e '/echo "Making $$target in $$subdir"; \\/d' \
84 -e 's/^srcdir = \(.*\)/srcdir = ./' \
85 -e 's/^builddir = \(.*\)/builddir = ./' \
86 -e 's/^all-am:.*/all-am:/' \
87 {} +
88
89 # Substitute links to installed binaries.
90 install -d "${D}${PTEST_PATH}/src/cli/"
91 ln -s "${bindir}/babeltrace2" ${D}${PTEST_PATH}/src/cli/
92
93 # Remove architechture specific testfiles
94 rm -rf ${D}${PTEST_PATH}/tests/data/plugins/flt.lttng-utils.debug-info/*
95}