summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng-2.0/lttng-tools_2.0.1.bb
diff options
context:
space:
mode:
authorBogdan Marinescu <bogdan.a.marinescu@intel.com>2012-05-24 22:49:19 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-05-25 11:18:03 +0100
commitf887fd6c001f585530bd4c0bcfe0f6397009959d (patch)
treefe7bccfce53f5b986eb9a3aa40759b45b17b1f71 /meta/recipes-kernel/lttng-2.0/lttng-tools_2.0.1.bb
parent02b91dbc79c13ec201fb934dfb567b52f217d8b8 (diff)
downloadpoky-f887fd6c001f585530bd4c0bcfe0f6397009959d.tar.gz
lttng-tools: updated to 2.0.1
Removed patch for ARM compilation, as it seems that the upstream fixed the ARM compilation problem in a slightly different way (tested by compiling lttng-tools for MACHINE=qemuarm) (From OE-Core rev: aa43a37da4f14b5a184f79b2ff43b0cd491e49af) Signed-off-by: Bogdan Marinescu <bogdan.a.marinescu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/lttng-2.0/lttng-tools_2.0.1.bb')
-rw-r--r--meta/recipes-kernel/lttng-2.0/lttng-tools_2.0.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng-2.0/lttng-tools_2.0.1.bb b/meta/recipes-kernel/lttng-2.0/lttng-tools_2.0.1.bb
new file mode 100644
index 0000000000..e7f10163df
--- /dev/null
+++ b/meta/recipes-kernel/lttng-2.0/lttng-tools_2.0.1.bb
@@ -0,0 +1,32 @@
1SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit Control"
3DESCRIPTION = "The Linux trace toolkit is a suite of tools designed \
4to extract program execution details from the Linux operating system \
5and interpret them."
6
7LICENSE = "GPLv2 & LGPLv2.1"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=61273c2e3f60dd38a74b01beb5f51fbd \
9 file://gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
10 file://lgpl-2.1.txt;md5=0f0d71500e6a57fd24d825f33242b9ca"
11
12DEPENDS = "liburcu popt lttng2-ust"
13
14SRCREV = "8c3919ea2dc77fdd47fb1c90e41490a20bb4d478"
15PV = "v2.0.1+git${SRCREV}"
16PR = "r0"
17
18SRC_URI = "git://git.lttng.org/lttng-tools.git;protocol=git"
19
20S = "${WORKDIR}/git"
21
22inherit autotools
23
24export KERNELDIR="${STAGING_KERNEL_DIR}"
25
26FILES_${PN} += "${libdir}/lttng/libexec/*"
27FILES_${PN}-dbg += "${libdir}/lttng/libexec/.debug"
28
29# Due to liburcu not building for MIPS currently this recipe needs to
30# be limited also.
31# So here let us first suppport x86/arm/powerpc platforms now.
32COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|powerpc.*)-linux'