summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_git.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2011-05-09 14:10:12 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-10 09:56:21 +0100
commitb4dcf0d1382762260883885682b57c96ca805f45 (patch)
treef220564ab065f5114467b885b1c9ad5ed881d22f /meta/recipes-kernel/linux/linux-yocto_git.bb
parent94c73db99c4a48b37979c589ef0972df1d152af8 (diff)
downloadpoky-b4dcf0d1382762260883885682b57c96ca805f45.tar.gz
linux-yocto: remove non-core (qemu) machine compatibility
The machine configuration of the non-core (non-qemu) machines exists in other layers. Moving the branch mappings, compatibility and SRCREVs of these machines out of the main linux-yocto recipe is the first step in that move. (From OE-Core rev: 9187ac0173f26c6a621229ff588f495e9967e665) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Acked-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_git.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_git.bb11
1 files changed, 1 insertions, 10 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_git.bb b/meta/recipes-kernel/linux/linux-yocto_git.bb
index 3b4e77e1bd..d4f2ecee63 100644
--- a/meta/recipes-kernel/linux/linux-yocto_git.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_git.bb
@@ -7,10 +7,6 @@ KMACHINE_qemux86-64 = "yocto/standard/common-pc-64/base"
7KMACHINE_qemuppc = "yocto/standard/qemu-ppc32" 7KMACHINE_qemuppc = "yocto/standard/qemu-ppc32"
8KMACHINE_qemumips = "yocto/standard/mti-malta32-be" 8KMACHINE_qemumips = "yocto/standard/mti-malta32-be"
9KMACHINE_qemuarm = "yocto/standard/arm-versatile-926ejs" 9KMACHINE_qemuarm = "yocto/standard/arm-versatile-926ejs"
10KMACHINE_atom-pc = "yocto/standard/common-pc/atom-pc"
11KMACHINE_routerstationpro = "yocto/standard/routerstationpro"
12KMACHINE_mpc8315e-rdb = "yocto/standard/fsl-mpc8315e-rdb"
13KMACHINE_beagleboard = "yocto/standard/beagleboard"
14 10
15KBRANCH = ${KMACHINE} 11KBRANCH = ${KMACHINE}
16KMETA = meta 12KMETA = meta
@@ -23,11 +19,6 @@ SRCREV_machine_qemumips = "f5d26f2eda2be8b942172cda8f27de33ebf38ec3"
23SRCREV_machine_qemuppc = "7eb6c68d977d9039a2b5a734172b064a9d19cdc1" 19SRCREV_machine_qemuppc = "7eb6c68d977d9039a2b5a734172b064a9d19cdc1"
24SRCREV_machine_qemux86 = "ad62d1aab734513cd96c8f4517f816420a218e77" 20SRCREV_machine_qemux86 = "ad62d1aab734513cd96c8f4517f816420a218e77"
25SRCREV_machine_qemux86-64 = "b906f358fd404a1e74a961f25079274e0d933ee1" 21SRCREV_machine_qemux86-64 = "b906f358fd404a1e74a961f25079274e0d933ee1"
26SRCREV_machine_emenlow = "c3bbcb676f929c4fc0511a6e66494b8770d015a1"
27SRCREV_machine_atom-pc = "b906f358fd404a1e74a961f25079274e0d933ee1"
28SRCREV_machine_routerstationpro = "95ca94d2e71ca2db6822a37a7f575fa79c3d05d0"
29SRCREV_machine_mpc8315e-rdb = "53c800c244e73d81d2832f6da306eeae3b09e5dc"
30SRCREV_machine_beagleboard = "b906f358fd404a1e74a961f25079274e0d933ee1"
31SRCREV_machine = "b906f358fd404a1e74a961f25079274e0d933ee1" 22SRCREV_machine = "b906f358fd404a1e74a961f25079274e0d933ee1"
32SRCREV_meta = "ecab1e2bc12a8b0c4d064a00acc3260f6e8528c5" 23SRCREV_meta = "ecab1e2bc12a8b0c4d064a00acc3260f6e8528c5"
33 24
@@ -37,7 +28,7 @@ SRCREV_FORMAT = "meta_machine"
37 28
38SRC_URI = "git://git.yoctoproject.org/linux-yocto-2.6.37;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta" 29SRC_URI = "git://git.yoctoproject.org/linux-yocto-2.6.37;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta"
39 30
40COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64|mpc8315e-rdb|routerstationpro|beagleboard)" 31COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64)"
41 32
42# Functionality flags 33# Functionality flags
43KERNEL_REVISION_CHECKING ?= "t" 34KERNEL_REVISION_CHECKING ?= "t"